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C8051F530A DEVELOPMENT KIT USER’S GUIDE

1.  Relevant Devices
The C8051F530A Development Kit is intended as a development platform for the microcontrollers in the
C8051F52xA-53xA MCU family. The members of this MCU family are C8051F520A, C8051F521A, C8051F523A,
C8051F524A, C8051F526A, C8051F527A, C8051F530A, C8051F531A, C8051F533A, C8051F534A,
C8051F536A, and C8051F537A.
Notes:

The target board included in this kit is provided with two pre-soldered C8051F530A-IT MCUs (TSSOP-20 
package).
Code developed on the C8051F530A can be easily ported to the other members of this MCU family.
Refer to the C8051F52x/52xA/53x/53xA data sheet for the differences between the members of this MCU 
family.

2.  Kit Contents
The C8051F530A Development Kit contains the following items:

• C8051F530A Target Board
• C8051Fxxx Development Kit Quick-Start Guide
• Silicon Laboratories IDE and Product Information CD-ROM. CD content includes:

• Silicon Laboratories Integrated Development Environment (IDE)
• Keil 8051 Development Tools (macro assembler, linker, evaluation C compiler)
• Source code examples and register definition files
• Documentation
• C8051F52xA-53xA Development Kit User’s Guide (this document)

• Optional Third Party Tools CD
• AC to DC Power Adapter
• USB Debug Adapter (USB to Debug Interface)
• USB Cable

The development kit target board contains two C8051530A microcontrollers that can communicate through a LIN
network. One of the C8051F530A (U2) can also be connected to a CP2102 USB to UART bridge and directly
connected to two analog signals and a Voltage Reference Signal Input.
The kit includes one USB Debug Adapter. Additionally, a second USB Debug Adapter and a second instance of the
Silicon Labs IDE can be used to communicate with both microcontrollers on the board at the same time using only
one PC.
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3.  Software Overview
All software required to develop firmware and communicate with the target microcontroller is included in the CD-
ROM. The CD-ROM also includes other useful software. 
Below is the software necessary for firmware development and communication with the target microcontroller:

Silicon Laboratories Integrated Development Environment (IDE)
Keil 8051 Development Tools (macro assembler, linker, evaluation C compiler)

Other useful software provided on the CD-ROM includes the following:
Configuration Wizard 2
Keil uVision Drivers
CP210x USB to UART Virtual COM Port (VCP) Drivers

3.1.  Software Installation
The included CD-ROM contains the Silicon Laboratories Integrated Development Environment (IDE), Keil software
8051 tools and additional documentation. Insert the CD-ROM into your PC’s CD-ROM drive. An installer will
automatically launch, allowing you to install the IDE software or read documentation by clicking buttons on the
Installation Panel. If the installer does not automatically start when you insert the CD-ROM, run autorun.exe found
in the root directory of the CD-ROM. Refer to the ReleaseNotes.txt file on the CD-ROM for the latest information
regarding known problems and restrictions. After installing the software, see the following sections for information
regarding the software and running one of the demo applications.

3.2.  CP210x USB to UART VCP Driver Installation
The C8051F530A Target Board includes a Silicon Laboratories CP2102 USB-to-UART Bridge Controller. Device
drivers for the CP2102 need to be installed before PC software (such as HyperTerminal) can communicate with the
target board over the USB connection. If the "Install CP210x Drivers" option was selected during installation, this
will launch a driver “unpacker” utility.
1. Follow the steps to copy the driver files to the desired location. The default directory is C:\SiLabs\MCU\CP210x.
2. The final window will give an option to install the driver on the target system. Select the “Launch the CP210x 

VCP Driver Installer” option if you are ready to install the driver.
3. If selected, the driver installer will now launch, providing an option to specify the driver installation location. After 

pressing the “Install” button, the installer will search your system for copies of previously installed CP210x 
Virtual COM Port drivers. It will let you know when your system is up to date. The driver files included in this 
installation have been certified by Microsoft.

4. If the “Launch the CP210x VCP Driver Installer” option was not selected in step 3, the installer can be found in 
the location specified in step 2, by default C:\SiLabs\MCU\CP210x\Windows_2K_XP_S2K3_Vista. At this 
location, run CP210xVCPInstaller.exe.

5. To complete the installation process, connect the included USB cable between the host computer and the USB 
connector (P1) on the C8051F530A Target Board. Windows will automatically finish the driver installation. 
Information windows will pop up from the taskbar to show the installation progress.

6. If needed, the driver files can be uninstalled by selecting “Silicon Laboratories CP210x USB to UART Bridge 
(Driver Removal)” option in the “Add or Remove Programs” window.
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3.3.  Silicon Laboratories IDE
The Silicon Laboratories IDE integrates a source-code editor, a source-level debugger, and an in-system Flash
programmer. See Section 5., "Using the Keil Software 8051 Tools with the Silicon Laboratories IDE‚" on page 6 for
detailed information on how to use the IDE. The Keil Evaluation Toolset includes a compiler, linker, and assembler
and easily integrates into the IDE. The use of third-party compilers and assemblers is also supported.
3.3.1. IDE System Requirements
The Silicon Laboratories IDE requirements:

Pentium-class host PC running Microsoft Windows 2000 or newer.
One available USB port.
64 MB RAM and 40 MB free HD space recommended.

3.3.2. Third Party Toolsets
The Silicon Laboratories IDE has native support for many 8051 compilers. The full list of natively supported tools is
as follows:

Keil
IAR
Raisonance
Tasking
Hi-Tech
SDCC

The demo applications for the C8051F530A Target Board are written to work with the Keil and SDCC toolsets.

3.4.  Keil Evaluation Toolset
3.4.1. Keil Assembler and Linker
The Keil demonstration toolset assembler and linker place no restrictions on code size.
3.4.2. Keil Evaluation C51 C Compiler
The evaluation version of the C51 compiler is the same as the full version with the following limitations: (1)
Maximum 4 kB code generation, (2) There is no floating point library included. When installed from the CD-ROM,
the C51 compiler is initially limited to a code size of 2 kB, and programs start at code address 0x0800. Refer to the
Application Note “AN104: Integrating Keil Tools into the Silicon Labs IDE" for instructions to change the limitation to
4 kB and have the programs start at code address 0x0000.
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3.5.  Configuration Wizard 2
The Configuration Wizard 2 is a code generation tool for all of the Silicon Laboratories devices. Code is generated
through the use of dialog boxes for each of the device's peripherals.

Figure 1. Configuration Wizard 2 Utility
The Configuration Wizard 2 utility helps accelerate development by automatically generating initialization source
code to configure and enable the on-chip resources needed by most design projects. In just a few steps, the wizard
creates complete startup code for a specific Silicon Laboratories MCU. The program is configurable to provide the
output in C or assembly language. For more information, refer to the Configuration Wizard documentation.
Documentation and software is available on the kit CD and from the downloads webpage: www.silabs.com/
mcudownloads.

3.6.  Keil µVision2 and µVision3 Silicon Laboratories Drivers
As an alternative to the Silicon Laboratories IDE, the µVision debug driver allows the Keil µVision2 and µVision3
IDEs to communicate with Silicon Laboratories on-chip debug logic. In-system Flash memory programming
integrated into the driver allows for rapidly updating target code. The µVision2 and µVision3 IDEs can be used to
start and stop program execution, set breakpoints, check variables, inspect and modify memory contents, and
single-step through programs running on the actual target hardware. For more information, refer to the µVision
driver documentation. The documentation and software are available from the downloads webpage:
www.silabs.com/mcudownloads.
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4.  Hardware Setup Using a USB Debug Adapter
The target board is connected to a PC running the Silicon Laboratories IDE via the USB Debug Adapter as shown
in Figure 2.

1. Connect the USB Debug Adapter to one of the DEBUG connectors on the target board (HDR1 or HDR2) 
with the 10-pin ribbon cable. The recommended connection is to the HDR2 (connected to U2) as this micro-
controller can be connected to the CP2102 USB to UART bridge.

2. Verify that shorting blocks are installed on J13 and J14 to supply power to the target devices.
3. Connect one end of the USB cable to the USB connector on the USB Debug Adapter. 
4. Connect the other end of the USB cable to a USB Port on the PC.
5. Connect the ac/dc power adapter to power jack P5 on the target board.

Notes:
• Use the Reset button in the IDE to reset the target when connected using a USB Debug Adapter.
• Remove power from the target board and the USB Debug Adapter before connecting or disconnecting the 

ribbon cable from the target board. Connecting or disconnecting the cable when the devices have power can 
damage the device and/or the USB Debug Adapter.

Figure 2. Hardware Setup using a USB Debug Adapter
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5.  Using the Keil Software 8051 Tools with the Silicon Laboratories IDE
To perform source-level debugging with the IDE, you must configure the Keil 8051 tools to generate an absolute
object file in the OMF-51 format with object extensions and debug records enabled. Build the OMF-51 absolute
object file by calling the Keil 8051 tools at the command line (e.g. batch file or make file) or by using the project
manager built into the IDE. The default configuration when using the Silicon Laboratories IDE project manager
enables object extension and debug record generation. Refer to Application Note "AN104: Integrating Keil 8051
Tools into the Silicon Labs IDE" in the “SiLabs\MCU\Documentation\ApplicationNotes” directory for additional
information on using the Keil 8051 tools with the Silicon Laboratories IDE. 
To build an absolute object file using the Silicon Laboratories IDE project manager, you must first create a project.
A project consists of a set of files, IDE configuration, debug views, and a target build configuration (list of files and
tool configurations used as input to the assembler, compiler, and linker when building an output object file).
The following sections illustrate the steps necessary to manually create a project with one or more source files,
build a program, and download it to the target in preparation for debugging. (The IDE will automatically create a
single-file project using the currently open and active source file if you select Build/Make Project before a project
is defined.) 

5.1.  Creating a New Project
1. Select Project→New Project to open a new project and reset all configuration settings to default.
2. Select File→New File to open an editor window. Create your source file(s) and save the file(s) with a 

recognized extension, such as .c, .h, or .asm, to enable color syntax highlighting.
3. Right-click on “New Project” in the Project Window. Select Add files to project. Select files in the file browser 

and click Open. Continue adding files until all project files have been added.
4. For each of the files in the Project Window that you want assembled, compiled, and linked into the target build, 

right-click on the file name and select Add file to build. Each file will be assembled or compiled as appropriate 
(based on file extension) and linked into the build of the absolute object file.

5. If a project contains a large number of files, the “Group” feature of the IDE can be used to organize. Right-click 
on “New Project” in the Project Window. Select Add Groups to project. Add pre-defined groups or add 
customized groups. Right-click on the group name and choose Add file to group. Select files to be added. 
Continue adding files until all project files have been added.

5.2.  Building and Downloading the Program for Debugging
1. Once all source files have been added to the target build, build the project by clicking on the Build/Make 

Project button in the toolbar or selecting Project→Build/Make Project from the menu.
Note: After the project has been built the first time, the Build/Make Project command will only build the files that have been

changed since the previous build. To rebuild all files and project dependencies, click on the Rebuild All button in the
toolbar or select Project→Rebuild All from the menu.

2. Before connecting to the target device, several connection options may need to be set. Open the Connection 
Options window by selecting Options→Connection Options . . . in the IDE menu. First, select the 
appropriate adapter in the “Serial Adapter” section. Next, the correct “Debug Interface” must be selected. 
C8051F52xA-53xA family devices use the Silicon Labs 2-wire (C2) debug interface. Once all the selections are 
made, click the OK button to close the window. 

3. Click the Connect button in the toolbar or select Debug→Connect from the menu to connect to the device. 
4. Download the project to the target by clicking the Download Code button in the toolbar.
Note: To enable automatic downloading if the program build is successful, select Enable automatic connect/download after

build in the Project→Target Build Configuration dialog. If errors occur during the build process, the IDE will not
attempt the download.

5. Save the project when finished with the debug session to preserve the current target build configuration, editor 
settings, and the location of all open debug views. To save the project, select Project→Save Project As . . . 
from the menu. Create a new name for the project and click on Save.
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6.  Example Source Code
Example source code and register definition files are provided in the “SiLabs\MCU\Examples\C8051F52xA_53xA”
directory during IDE installation. These files may be used as a template for code development. Example
applications include a blinking LED example which configures the green LED on the target board to blink at a fixed
rate.

6.1.  Register Definition Files
Register definition files C8051F520A.inc and C8051F520A_defs.h define all SFR registers and bit-addressable
control/status bits. A macro definition header file compiler_defs.h is also included and is required to be able to use
the C8051F520A_defs.h header file with various tool chains. These files are installed by default into the
“SiLabs\MCU\Examples\C8051F52xA_53xA\Header_Files” directory during IDE installation. The register and bit
names are identical to those used in the C8051F52x/52xA/53x/53xA data sheet. The register definition files are
also installed in the default search path used by the Keil Software 8051 tools. Therefore, when using the Keil 8051
tools included with the development kit (A51, C51), it is not necessary to copy a register definition file to each
project’s file directory.

6.2.  Blinking LED Example
The example source files F530A_Blinky.asm and F530A_Blinky.c installed in the default directory
“SiLabs\MCU\Examples\C8051F52xA_53xA\Blinky” show examples of several basic C8051F52xA-53xA functions.
These include disabling the watchdog timer (WDT), configuring the Port I/O crossbar, configuring a timer for an
interrupt routine, initializing the system clock, and configuring a GPIO port. When compiled/assembled and linked,
this program flashes the green LED on the C8051F530A Target Board associated with the microcontroller about
five times a second using the interrupt handler with a C8051F530A timer.
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7.  Target Board
The C8051F52xA-53xA Development Kit includes a target board with two C8051F530A devices pre-installed for
evaluation and preliminary software development. Numerous input/output (I/O) connections are provided to
facilitate prototyping using the target board. Refer to Figure 3 for the locations of the various I/O connectors.

P5 Power connector (Accepts input from 7 to 15 VDC unregulated power adapter.)
PWR Red Power-on LED (D3)
TB1 LIN connector
U5 5 V Voltage Regulator

"A" Side:

J2 28-pin Expansion I/O connector for U2
HDR2 Debug connector for Debug Adapter Interface
P1.3_A Green LED (D2)
Reset_A Reset button
P1.4_A Push button
R32 Potentiometer for P1.2_A 
J6, J8 Connects R32 (potentiometer) to U2 and +5 V
J13 Connects power to U2 
J11, J12 Connects external crystal to U2 pins P0.7_A and P1.0_A
J3 Connects analog channel 1 to U2 P1.6_A
J4 Connects analog channel 2 to U2 P1.7_A
J5 Connects VREFIN to U2 P0.0_A
TB2 Analog input connector
HDR4 Connector block for serial port connection, Green LED, and push-button
U3 Silicon Laboratories CP2102 USB-to-UART Bridge
P1 USB connector to serial interface (CP2102)
USB ACTIVE Red USB Active LED (D4) (CP2102)
T2 LIN transceiver 
U2 C8051F530A "A" Side

"B" Side:

J1 26-pin Expansion I/O connector for U1
HDR1 Debug connector for Debug Adapter Interface 
P1.3_B Green LED (D1)
Reset_B Reset button 
P1.4_B Push button 
J14 Connects power to U1
J9, J10 Connects external crystal to U1 pins P0.7_B and P1.0_B
HDR3 Green LED and push-button connector block 
T1 LIN transceiver 
U1 C8051F530A "B" Side
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7.1.  Target Board Shorting Blocks: Factory Defaults
The C8051F530A target board comes from the factory with pre-installed shorting blocks on many headers.
Figure 3 shows the positions of the factory default shorting blocks.

Figure 3. C8051F530A Target Board
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The C8051F530A device installed on the target board features a calibrated programmable internal oscillator which
is enabled as the system clock source on reset. After reset, the internal oscillator operates at a frequency of
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many applications an external oscillator is not required. However, if you wish to operate the C8051F530A device at
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7.3.  Switches and LEDs
Four switches are provided on the target board. 
Switch RESET_A is connected to the RESET pin of the C8051F530A A-Side (U2).
Switch RESET_B is connected to the RESET pin of the C8051F530A B-Side (U1).
Pressing  RESET_A or RESET_B puts the attached device into its hardware-reset state.
Switches P1.4_A and P1.4_B are connected to the C8051F530A parts (U1 and U2) general purpose I/O (GPIO)
pins through headers. Pressing P1.4_A or P1.4_B generates a logic low signal on the port pin of the respective
microcontroller. 
Remove the shorting block from the header to disconnect P1.4_A or P1.4_B from the port pins. The port pin
signals are also routed to pins on the J1 and J2 I/O connectors. See Table 1 for the port pins and headers
corresponding to each switch.
Four LEDs are also provided on the target board. The red LED labeled PWR is used to indicate a power
connection to the target board. The green LEDs labeled D1 and D2 are connected to the C8051F530A's GPIO pins
through headers. Remove the shorting blocks from the headers to disconnect the LEDs from the port pins. The port
pin signals are also routed to pins on the J1 and J2 I/O connectors. The red LED labeled USB ACTIVE is used to
indicate that the CP2102 USB-to-UART bridge is properly connected to a PC and is ready for communication. See
Table 1 for the port pins and headers corresponding to each LED.
A potentiometer (R32) is provided on the target board.  Header J8 connects the potentiometer to +5 V and header
J6 connects the potentiometer to the P1.2_A pin of the U2 A-Side C8051F530A microcontroller.

Table 1. Target Board I/O Descriptions

Description I/O Header
Reset_A U2-Reset none
Reset_B U1-Reset none
P1.4_A U2-P1.4 HDR4[3–4]
P1.4_B U1-P1.4 HDR3[3–4]

Green LED D2 U2-P1.3 HDR4[1–2]
Green LED D1 U1-P1.3 HDR3[1–2]
Red LED D3 PWR none
Red LED D4 USB ACTIVE none

Potentiometer R32 U2-P1.2 J6, J8



C8051F530A-DK

Rev. 0.3 11

7.4.  Expansion I/O Connectors (J1, J2)
The two Expansion I/O connectors J1 (26 pins) and J2 (28 pins) provide access to all signal pins of the
C8051F530A devices. Pins for VDD, GND, 5 V, Reset, Vbat, LIN, 3.3 V and VREFIN are also available. A small
through-hole prototyping area is also provided.
All I/O signals routed to connectors J1 and J2 are also routed to through-hole connection points between J1 and J2
and the prototyping area (see Figure 3 on page 9). Each connection point is labeled indicating the signal available
at the connection point. See Table 2 for a list of pin descriptions for J1 and J2.

7.5.  Target Board DEBUG Interface (HDR1, HDR2)
The DEBUG connectors (HDR1 and HDR2) provide access to the DEBUG (C2) pins of the C8051F530A parts.
They are used to connect the USB Debug Adapter to the target board for in-circuit debugging and Flash
programming. Table 3 shows the DEBUG pin definitions.

Table 2. Pin Descriptions for J1 and J2

J1 J2
Pin # Description Pin # Description Pin # Description Pin # Description

1 P0.0_B 14 P1.5_B 1 P0.0_A 15 P1.6_A

2 P0.1_B 15 P1.6_B 2 P0.1_A 16 P1.7_A

3 P0.2_B 16 P1.7_B 3 P0.2_A 17 +5V

4 P0.3_B 17 +5V 4 P0.3_A 18 RST/C2CLK_A

5 P0.4_B 18 RST/C2CLK_B 5 P0.4_A 19 VBAT

6 P0.5_B 19 VBAT 6 P0.5_A 20 LIN

7 P0.6_B 20 LIN 7 P0.6_A 21 VREFIN

8 P0.7_B 21 NC 8 P0.7_A 22 VREGOUT_A

9 P1.0_B 22 VREGOUT_B 9 P1.0_A 23 +3.3V

10 P1.1_B 23 NC 10 P1.1_A 24 NC

11 P1.2_B 24 NC 11 P1.2_A 25 NC

12 P1.3_B 25 GND 12 P1.3_A 26 NC

13 P1.4_B 26 GND 13 P1.4_A 27 GND

14 P1.5_A 28 GND

Table 3. DEBUG Connector Pin Descriptions

Pin # Description
1 +3 VD (+3.3 VDC)

2, 3, 9 GND (Ground)

4 C2D

5 RST (Reset)

6 P0.6

7 C2CK

8 Not Connected

10 USB Power
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7.6.  USB to Serial Connector (P1, HDR4)
A USB-to-Serial bridge interface is provided. A B-type USB connector (P1), a CP2102, and related circuits are
provided  to facilitate the serial connection between a PC and the U2 A-Side C8051F530A microcontroller on the
target board. The RX, TX, CTS, and RTS signals of the UART side of the Bridge (CP2102) may be connected to
the microcontroller by installing shorting blocks on HDR4 as shown in Table 4.

The BUS-Powered CP2102 uses the 5 V provided by the USB interface.

7.7.  Analog I/O (TB2, J3, J4, J5)
The Analog connector block (TB2) and headers J3, J4, and J5 provide Analog inputs to the C8051F530A (U2) as
shown in Table 5.  Headers J3, J4, and J5 connect the inputs from the Analog connector to the microcontroller pins.

7.8.  Power Supply Options (P5, TB1, J13, J14)
The target board provides two options of power supply. The first option is to use the provided 9 V power supply
attached to the P5 connector. The second option is to use an external 12 V (7.5 V minimum) connected to the TB1
terminal block (pins 1 and 3).
Headers J13 and J14 connect the +5 V power supply to the VREGIN pins on U1 and U2.  These headers can be
populated to supply power directly or depopulated to measure the operating current drawn by the corresponding
C8051F530A device.

7.9.  LIN Connectivity (TB1)
The C8051F530A Target Board has two C8051F530A devices (U1 and U2) and two LIN transceivers (T1 and T2)
to provide LIN connectivity on the target board. These devices can also be interfaced to another LIN bus using the
TB1 terminal block.

Table 4. UART Connections

HDR3
Connection Signals

5–6 P0.4_A to TX_A
7–8 P0.5_A to RX_A
9–10 P1.1_A to RTS_A
11–12 P1.2_A to CTS_A

Table 5. Analog I/O Connections

TB2
Signal Connection I/O Shorting Block
Vrefin External Reference Input or Internal Reference Output P0.0_A J5
CH1 Analog Input 1 P1.6_A_MC J3
CH2 Analog Input 1 P1.7_A_MC J4
GND Ground GND —

Table 6. LIN Connections
TB1

Signal Connection
+12V Supplies 12 V (7.5 V minimum) to the target board. This can be connected to the power supply of 

another LIN bus or any external supply.
LIN Connects the 12 V LIN bus signal to the T1 and T2 LIN transceivers.

GND Ground
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8.  Schematics
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DOCUMENT CHANGE LIST

Revision 0.2 to Revision 0.3
Updated for C8051F530A TB.
Added "LIN Connectivity (TB1)‚" on page 12.
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NOTES:
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CONTACT INFORMATION
Silicon Laboratories Inc.
400 West Cesar Chavez
Austin, TX 78701
Tel: 1+(512) 416-8500
Fax: 1+(512) 416-9669
Toll Free: 1+(877) 444-3032
Email: MCUinfo@silabs.com
Internet: www.silabs.com

Silicon Laboratories and Silicon Labs are trademarks of Silicon Laboratories Inc.
Other products or brandnames mentioned herein are trademarks or registered trademarks of their respective holders.

The information in this document is believed to be accurate in all respects at the time of publication but is subject to change without notice. 
Silicon Laboratories assumes no responsibility for errors and omissions, and disclaims responsibility for any consequences resulting from 
the use of information included herein. Additionally, Silicon Laboratories assumes no responsibility for the functioning of undescribed features 
or parameters. Silicon Laboratories reserves the right to make changes without further notice. Silicon Laboratories makes no warranty, rep-
resentation or guarantee regarding the suitability of its products for any particular purpose, nor does Silicon Laboratories assume any liability 
arising out of the application or use of any product or circuit, and specifically disclaims any and all liability, including without limitation conse-
quential or incidental damages. Silicon Laboratories products are not designed, intended, or authorized for use in applications intended to 
support or sustain life, or for any other application in which the failure of the Silicon Laboratories product could create a situation where per-
sonal injury or death may occur. Should Buyer purchase or use Silicon Laboratories products for any such unintended or unauthorized ap-
plication, Buyer shall indemnify and hold Silicon Laboratories harmless against all claims and damages. 



 

 

 

Мы молодая и активно развивающаяся компания в области  поставок 

электронных компонентов. Мы поставляем  электронные  компоненты  

отечественного и импортного производства напрямую от производителей и с 

крупнейших складов мира. 

Благодаря сотрудничеству с мировыми поставщиками мы осуществляем 

комплексные и плановые поставки   широчайшего   спектра электронных 

компонентов. 

Собственная  эффективная  логистика и склад в обеспечивает надежную 

поставку продукции в точно указанные сроки по всей России. 

Мы осуществляем  техническую поддержку нашим клиентам и 

предпродажную проверку качества продукции. На  все поставляемые продукты 

мы предоставляем  гарантию . 

Осуществляем поставки продукции под контролем ВП МО РФ на 

предприятия военно-промышленного комплекса  России , а также работаем в 

рамках 275 ФЗ с открытием отдельных счетов в уполномоченном банке. Система 

менеджмента качества компании соответствует требованиям ГОСТ ISO 9001.  

Минимальные сроки поставки, гибкие цены, неограниченный 

ассортимент  и индивидуальный подход к клиентам являются основой для 

выстраивания долгосрочного и эффективного сотрудничества с предприятиями 

радиоэлектронной промышленности, предприятиями  ВПК и научно-

исследовательскими  институтами России. 

С нами вы становитесь  еще успешнее! 

 

 

 

 

 

Наши контакты: 

Телефон: +7 812 627 14 35 

Электронная почта: sales@st-electron.ru 

Адрес: 198099, Санкт-Петербург,  

Промышленная ул, дом № 19, литера Н,  

помещение 100-Н Офис 331 

mailto:sales@st-electron.ru

