ROHM

User’s Guide

Sensor Evaluation Kit

SensorShield-EVK-003 Manual

SensorShield-EVK-003 is a Kit, which are included the 8 kinds of Sensor and Shield-EVK-001 which connects Arduino and ROHM Sensor Boards.
Shield-EVK-001 will be referred to as “SensorShield” on this manual.

Board Information

No.| ___Sensor | Type Name _

Preparation

Arduino Uno 1pc
Accelerometer KX224-12C ) )

Personal Computer installed Arduino IDE 1pc
Pressure Sensor BM1383AGLV . ) i

»  Requirement : Arduino 1.6.7 or higher
Magnetometer BM1422AGMV ) )

»  Please use Arduino IDE which can be
ALS/PS Sensor RPR-0521RS )

downloaded from the link below:

Color Sensor BH1749NUC

http://www.arduino.cc/
BH1790GLC ®  USB cable for connecting Arduino and PC 1pc

Optical Sensor for
Heart Rate Monitor

Hall Sensor BD7411G ®  SensorShield-EVK-003 1pc
Temperature Sensor BD1020HFV

0 N O O b~ 0N -

Setting for Board and Software

Table 1. Sensor lineup
The following explanation is about a connection method of

SensorShield Detail BM1422AGMV-EVK-001 which is I2C connection sensor.
® Connection Board between Arduino and ROHM Sensor
Board (Figure 1)

Size: 88mm x 63mm

1. Connect the SensorShield to the Arduino (Figure 2)

SensorShield
USB connecter
Five I12C Sensors, One I/O Sensor and Two Analog

Sensors can be controlled

® 5V-3.0/1.8V Level Shifter
»  GPIO : FAIRCHILD FXMA108
» 12C : NXP PCA9306

»  12C pull-up register is implemented

Figure 2. Connection between the Arduino and the
SensorShield

..........................

————— ® £ T 2. Connect BM1422AGMV-EVK-001 to the socket of 12C_1
Figure 1. SensorShield on the SensorShield (Figure 3)
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3.  Set Voltage of the SensorShield to 1.8V or 3.0V (Figure 3)
4.  Set Interrupt of the SensorShield to INTR1 (Figure 3)
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Figure 3. Connection between BM1422AGMV-EVK-001 and
the SensorShield

5.  Connect the Arduino to the PC using a USB cable

6. Download BM1422AGMV.zip from the link below:
http://www.rohm.com/web/global/sensor-shield-support
Launch Arduino IDE
Select [Sketch]->[Include Library]->[Add.ZIP library...],
install BM1422AGMV.zip

9. Select [File]->[Examples]->[BM1422AGMV]->[example]-
>[BM1422AGMV]

Measurement

1. Select [Tools] and check the contents enclosed in the red

frame. (Figure 4) Board should be “Arduino/Genuino Uno”
and Port should be COMxx (Arduino/Genuino Uno). COM

port number is different in each environment.

€ BM1422AGMV | Arduino 1.6.13 - o X

File Edit Sketch Tools Help

Auto Format Curl+T
Archive Sketch

Fix Encoding & Reload

Serial Monitor Ctrl+Shift+M
Serial Plotter Ctri+Shift+L

WiFi101 Firmware Updater

Board: "Arduino/Genuino Uno® >
Port: "COM13 (Arduino/Genuino Uno)* >
S—

Get Board Info
Programmer: "AVRISP mkil* >

Bum Bootloader
Figure 4. COM Port setting

2. Write the program by pressing right arrow button for

upload (Figure 5)

< i o »
Ty ol

Wait for the message “Done uploading” (Figure 5)

& BM1422AGMV | Arduino 1.6.13 - (m] X

FilelEdit Sketch Tools Help

BM1422AGMV

| ~

Figure 5. Uploading

Select [Tools]->[Serial Monitor] (Figure 6)

@ BM1422AGMV | Arduino 1.6.13 - o X
File Edit Sketch Tools Help

Auto Format T
Archive Sketch
BM142280MV, Fix Encoding & Reload

| _Serial Monitor Ctrl+Shift+M |
Serial Plotter Ctri+Shift+L

WiFi101 Firmware Updater

Board: "Arduino/Genuino Uno" >
Port: "COM13 (Arduino/Genuino Uno)* >
Get Board Info

Programmer: "AVRISP mkil* >
Burn Bootloader

Figure 6. Tools Setting
Check log of Serial Monitor (Figure 7)

& COM7 (Arduing/Genuino Uing)

BM1422AGMY XDATA=-36.083[uT]
SBMI422AGMY YDATA=-23. 167 [uT]
BM1422AGMY ZDATA=-45.542[uT]

BMI1422AGMV XDATA=-36.042[uT]
BMI422AGMV YDATA=-23. 458[uT]
JBMI4224GMV ZDATA=-45.417(uT]

EM1422AGMV XDATA=-35.125[uT]
0 ABMI422AGMY YDATA=-23.292[uT]
B EM1422AGMY ZDATA=-45.417[uT]

R [EM1422AGMYV XDATA=-35.792[uT]

vle

MM 4224GMY_WIA Register Value = Ox41 2

v
>

Ho lrw ercing - 9600 baud

Figure 7. Serial Monitor
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Three kinds of connection method

The following explanation is about three kinds of connection

methods of I12C Sensor, I/0 Sensor and Analog Sensor.

1. 12C Sensor (Example: KX224-12C)

[Setting for Program]

Select [File]->[Examples]->[KX224-12C]->[example]->[KX224-
12C]

Check log of Serial Monitor according to measurement method

[Measurement]
Get the data of each X, Y, Z axis of KX224-12C every 500ms
and display it.(Figure 8)

@

D COM7 (Arduine/Genuine Uno) - o x

=0.98 [éi‘

“[kx224 () = -0.00 [&]

Kx224 (Y) = 0.01 [g]

Kx224 (Z) = 1.00 [g]

kX224 (X) = 0.00 [g]

Kx224 (Y) = 0.00 [g]

. efkxzze (2) = 0.98 [g]

Kx224 (X) = 0.00 [g]

Kx224 (Y) = 0.01 [g]

kX224 (Z) = 0.99 [g]
. >"< >V
TS ) Auicscroll Mo i ending | (BB 5aid

Figure 8. Serial Monitor (KX224-12C)

2. 1/O Sensor (Example: BD7411G)
[Setting for Program]
Select [File]->[Examples]->[BD7411G]->[example]->[BD7411G]

Check log of Serial Monitor according to measurement method

[Measurement]

Check the output of BD7411G every 500ms, and when the
output is low, display a message (Figure 9)

*Notice : When a program of BD7411G is written, please
remove BD7411G-EVK-001.

@ BD7a11 | Arduine 1613 - u] ®

File Edit Sketch Tools Help

BD7411G Magnet field Detect!
BD7411G Magnet field Detect!
«[BO7411G Magnet field Detect!

BD7411G Magnet field Detect!
BD7411G Magnet field Detect!

< >
Mo line ending | | 9600 baud

Figure 9. Serial Monitor (BD7411G)

3.
[Setting for Program]

Select [File]->[Examples]->[BD1020HFV]->[example]-
>[BD1020HFV]

Check log of Serial Monitor according to measurement method

Analog Sensor (Example: BD1020HFV)

[Measurement]

Convert the output of BD1020HFYV into temperature every

500ms and display a message (Figure 10)

@

& coMT (Arduina/Genuing Ling) - o x
Serd
D1020HFY Samp e -
D1020HFY Temp=15.26 [degrees Celsius.
01020HFY Temp=14.07 [degrees Celsius,
D1020HFY Tenp=14.07 [degrees Celsius.
D1020HFY Temp=14.07 [degrees Celsius]
D10Z0HFY Temp=14.07 [degrees Celsius.
DI10Z0HFY Temp=14.07 [degrees Celsius.
D10Z0HFY Temp=14.07 [degrees Celsius’
D1020HFYV Temp=14.07 [degrees Celsius.
D10Z0HFY Temp=14.07 [degrees Celsius.
D1020HFY Temp=14.66 [degrees Celsius.
010Z0HFY Temp=15.26 [degrees Celsius.
D1020HFY Temp=15.26 [degrees Celsius.
D1020HFY Temp=15.85 [degrees Celsius.
D1020HFV Temp=15.85 [degrees Celsius.

Updates available for some of your boards and librared [ Buteseall

Ho lins ending - | |$600baud  +

Figure 10. Serial Monitor (BD1020HFV)
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Notice

10)

11)

12)

13)

Notes

The information contained herein is subject to change without notice.

Before you use our Products, please contact our sales representative and verify the latest specifica-
tions :

Although ROHM is continuously working to improve product reliability and quality, semicon-
ductors can break down and malfunction due to various factors.

Therefore, in order to prevent personal injury or fire arising from failure, please take safety
measures such as complying with the derating characteristics, implementing redundant and
fire prevention designs, and utilizing backups and fail-safe procedures. ROHM shall have no
responsibility for any damages arising out of the use of our Poducts beyond the rating specified by
ROHM.

Examples of application circuits, circuit constants and any other information contained herein are
provided only to illustrate the standard usage and operations of the Products. The peripheral
conditions must be taken into account when designing circuits for mass production.

The technical information specified herein is intended only to show the typical functions of and
examples of application circuits for the Products. ROHM does not grant you, explicitly or implicitly,
any license to use or exercise intellectual property or other rights held by ROHM or any other
parties. ROHM shall have no responsibility whatsoever for any dispute arising out of the use of
such technical information.

The Products specified in this document are not designed to be radiation tolerant.

For use of our Products in applications requiring a high degree of reliability (as exemplified
below), please contact and consult with a ROHM representative : transportation equipment (i.e.
cars, ships, trains), primary communication equipment, traffic lights, fire/crime prevention, safety
equipment, medical systems, servers, solar cells, and power transmission systems.

Do not use our Products in applications requiring extremely high reliability, such as aerospace
equipment, nuclear power control systems, and submarine repeaters.

ROHM shall have no responsibility for any damages or injury arising from non-compliance with
the recommended usage conditions and specifications contained herein.

ROHM has used reasonable care to ensure the accuracy of the information contained in this
document. However, ROHM does not warrants that such information is error-free, and ROHM
shall have no responsibility for any damages arising from any inaccuracy or misprint of such
information.

Please use the Products in accordance with any applicable environmental laws and regulations,
such as the RoHS Directive. For more details, including RoHS compatibility, please contact a
ROHM sales office. ROHM shall have no responsibility for any damages or losses resulting
non-compliance with any applicable laws or regulations.

When providing our Products and technologies contained in this document to other countries,
you must abide by the procedures and provisions stipulated in all applicable export laws and
regulations, including without limitation the US Export Administration Regulations and the Foreign
Exchange and Foreign Trade Act.

This document, in part or in whole, may not be reprinted or reproduced without prior consent of
ROHM.

Thank you for your accessing to ROHM product informations.
More detail product informations and catalogs are available, please contact us.

ROHM ROHM Customer Support System

SEMICONDUCTOR

http://www.rohm.com/contact/

www.rohm.com

© 2016 ROHM Co., Ltd. All rights reserved.
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No.| __ Sensor | _Type Name

Accelerometer
Pressure sensor
Magnetometer
ALS/PS sensor
Color sensor

a B~ W N -

Optical Sensor for
Heart Rate Monitor

Hall sensor

8  Temperature sensor

Accelerometer

|O_VDD
2 Pressure sensor BM1383AGLV VDD
AVDD
2 Magnetometer BM1422AGMV
DVDD
VCC
4 ALS/PS sensor RPR-0521RS
VLEDA
5 Color sensor BH1749NUC Vce
Optical Sensor for VDD
6 Heart Rate Monitor BH1790GLC VLED
Hall sensor BD7411G VDD
Temperature sensor  BD1020HFV VDD

KX224-12C
BM1383AGLV

BM1422AGMV

RPR-0521RS
BH1749NUC

BH1790GLC

BD7411G
BD1020HFV

12C_1,12C_2,12C_3,12C_4,12C_5
12C_1,12C_2,12C_3,12C_4,12C_5
12C_1,12C_2,12C_3,12C_4,12C_5
12C_1,12C_2,12C_3,12C_4,12C_5
12C_1,12C_2,12C_3,12C_4,12C_5

12C_1,12C_2,12C_3,12C_4,12C_5

GPIO
ANALOG_2

Table 2. Connection Area of each sensor

KX224-12C

1.71
1.7
1.7
1.7
1.7
25
2.8
23
2.5
3.6
4.5
24

Recommended

2.5 3.6
O O
VDD
3.6 O O
3.6
O O
3.6
3.0 3.6
O
3.0 5.5
25 3.6 O
3.0 3.6 O
5.5 O
5.0 5.5 O
3.0 5.5 O @)

Table 3. The Operating Voltage of each sensor

(No.|  Sensor | Type Name Device Address(7bit)

Accelerometer
Pressure sensor
Magnetometer
ALS/PS sensor
Color sensor

Optical Sensor for
Heart Rate Monitor

D Ok W N -

KX224-12C
BM1383AGLV

BM1422AGMV

RPR-0521RS
BH1749NUC

BH1790GLC

Ox1E/Ox1F
0x5D
OxOE/OxOF
0x38
0x38/0x39

0x5B

[ Blue character is default device address ]

Table 4. Device Address of the 12C Sensor
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Mouser Electronics

Authorized Distributor

Click to View Pricing, Inventory, Delivery & Lifecycle Information:

ROHM Semiconductor:
SENSORSHIELD-EVK-003



https://www.mouser.com/rohm-semiconductor
https://www.mouser.com/access/?pn=SENSORSHIELD-EVK-003

CraHpapT
INeKTpPOoH
ﬂ CBAA3b

Mbl MOf04aA M aKTUBHO Pa3BMBAIOLLAACA KOMMAHWA B 061acTM  MOCTaBOK
3NEKTPOHHbIX KOMMOHEHTOB. Mbl NOCTAaBASEM  3/IEKTPOHHbIE  KOMMOHEHTbI
OTEYEeCTBEHHOIrO U MMMOPTHOIO NMPOWU3BOACTBA HAMPAMYIO OT NPOU3BOAMUTENEN U C
KpYMHEMLWKNX CKNaZ0B MUpa.

Enaro,a,apﬂ coTpygHn4ecTtesy C MMpPOBbIMU NOCTaBWMKaMWN Mbl OCYLLECTBIAEM
KOMMNNEKCHbIE N NN1aHOBblE MNMOCTABKU LumpoqaﬁLuero CNEeKTpa 3/1EKTPOHHbIX
KOMMOHEHTOB.

CobcTtBeHHan 3¢p@eKTUBHAA NOrMCTUKA M CKNag B obecneunBaeT HageKHYHo
MOCTaBKy MNPOAYKLMM B TOYHO YKa3aHHble CPOKM Mo Bcel Poccum.

Mbl ocyuiecTBisem TEXHUYECKYI0 MNOALEPKKY HAWWM  K/IMEHTaMm U
npeanpoaaxkHyto NPOBEPKY KayecTsa NpoayKumu. Ha Bce noctaBnsiemble NpoAyKTbl
Mbl MPEAOCTaBASEM TFAPaAHTUIO .

OcyuwiectBndem nNOCTaBKM NpoOAYKUMM nog, KoHTponem Bl MO PO Ha
npeanpuATUA BOEHHO-NPOMbIWIEHHOTO KoMnaekca Poccuun , a TakKe paboTtaem B
pamkax 275 ®3 c OTKpbITUEM OTAE/bHbIX CHETOB B YNONHOMOYEHHOM BaHKe. Cuctema
MeHeXMeHTa KayecTBa KomnaHum cooTBeTcTByeT TpeboBaHuam FOCT ISO 9001.

MWHUMaNbHbIE  CPOKM  MNOCTAaBKW, TMOKME  UeHbl, HeorpaHWYeHHbIN
aCCOPTUMEHT UM WHAMBMAYANbHbLIN MNOAXOA K KAMEHTaM ABAAIOTCA OCHOBOW ANA
BbICTPAMBaHMA A0FOCPOYHOIO M 3GPEKTUBHOIO COTPYAHMYECTBA C NPEeANPUATUAMM
PaANO3NEKTPOHHOMW NPOMBIWAEHHOCTU, NPEeanPUATUAMM BMNK u HayuHo-
nccnenoBaTeNbCKUMKU MHCTUTYTaMm Poccun.

C Hamu Bbl CTAaHOBMUTECH elle ycnewHee!

[HaLLIM KOHTAKTbI: \

TenedoH: +7 812 627 14 35

dNeKTpPOHHaA nouTa: sales@st-electron.ru

Appec: 198099, CaHkT-MNeTepbypr,
MpomblwneHHasa yn, gom Ne 19, nutepa H,
nometleHune 100-H Oduc 331
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