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We want your feedback! 
 
SofTec Microsystems is always on the look-out for new ways to improve its Products and 
Services. For this reason feedback, comments, suggestions or criticisms, however small, 
are always welcome. 

 
 
 
 
 

 
 

 

Our policy at SofTec Microsystems is to comply with all applicable worldwide safety and 
EMC/EMI regulations. Our products are certified to comply to the European New 
Approach Directives and the CE mark is applied on all our products. 
This product as shipped from the factory has been verified to meet with requirements 
FCC as a CLASS A product. 
This product is designed and intended for use as a development platform for hardware or 
software in an educational or professional laboratory. 
In a domestic environment, this product may cause radio interference in which case the 
user may be required to take adequate prevention measures. 
Attaching additional wiring to this product or modifying the product operation from the 
factory default as shipped may effect its performance and cause interference with other 
apparatus in the immediate vicinity. If such interference is detected, suitable mitigating 
measures should be taken. 

 
 
 
SofTec Microsystems 
E-mail (general information): info@softecmicro.com 
E-mail (marketing department): marketing@softecmicro.com 
E-mail (technical support): support@softecmicro.com 
Web: http://www.softecmicro.com 
 

Important 
SofTec Microsystems reserves the right to make improvements to this product, its documentation and software routines, 
without notice. Information in this manual is intended to be accurate and reliable. However, SofTec Microsystems assumes no 
responsibility for its use; nor for any infringements of rights of third parties which may result from its use. 
SOFTEC MICROSYSTEMS WILL NOT BE LIABLE FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE 
OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY 
THEREOF. 
Trademarks 
SofTec Microsystems is a registered trademark of SofTec Microsystems, Spa. 
Freescale™ and the Freescale logo are trademarks of Freescale Semiconductor, Inc. 
Microsoft and Windows are trademarks or registered trademarks of Microsoft Corporation. 
PC is a registered trademark of International Business Machines Corporation. 
Other products and company names listed are trademarks or trade names of their respective companies.
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1 Introduction 

1.1 Overview 

The DEMO9S08LC60 Demonstration board has been designed for the evaluation, 
demonstration and the debugging of the Freescale MC9S08LC60 microcontroller.  
The DEMO9S08LC60 can be used as a standalone application, or via its built-in USB-to-BDM 
bridge, or together the Freescale Student Learning Kit (Freescale code: MCUSLK) through an 
external 40-pin I/O header female connector. 

1.2 Package Contents 

The DEMO9S08LC60 package includes the following items: 
 
� The DEMO9S08LC60 evaluation board; 
� A USB cable; 
� The SofTec Microsystems “System Software” CD-ROM; 
� The CodeWarrior Development Studio Special Edition CD-ROM; 
� A Quick Start Guide sheet; 
� This user’s manual. 

1.3 Supported Devices 

The DEMO9S08LC60 Demonstration Board supports the following devices: 

 
� MC9S08LC60. 

1.4 Recommended Reading 

� Freescale S08 microcontroller-specific datasheets; 
� DEMO9S08LC60 Schematic. 
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i 
 

Note: the MC9S08LC60 datasheet is available for download at 
www.freescale.com. 
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2 Hardware Features 

2.1 Demonstration Board Features 

The DEMO9S08LC60 board features: 
 
� A MC9S08LC60 microcontroller (in 80-pin LQFP package, already programmed with a 

demo application); 
� One clock sources: a 32.768 KHz crystal, selectable via the “CLK ENA” jumpers. 
� A 12 V DC Power Supply Input Connector; 
� Power input selection jumpers for selecting the input voltage source: 
 

o 12 V DC input connector; 
o USB connector; 

 
� A built-in USB-to-BDM circuitry which allows the host PC to communicate with the 

microcontroller through a standard USB interface. USB 2.0 is fully supported. When 
using an external in-circuit debugger (via the “BDM” connector), the USB-to-BDM 
circuitry must be bypassed by removing the BKGD and  RESET# jumpers in the “IO2 
ENA” jumper strip. 

� A Reset push-button connected to the MCU Reset pin.  
� A series of inputs: 
 

o Four push-buttons together with jumpers to connect/disconnect them to/from the 
microcontroller; 

o A potentiometer, together with a jumper to connect/disconnect it to/from the PTA0 
pin of the microcontroller; 

o An NTC-based temperature sensor, together with a jumper to connect/disconnect 
it to/from the PTA7 pin of the microcontroller; 

o A photocell, together with a jumper to connect/disconnect it to/from the PTA1 pin 
of the microcontroller; 

o An accelerometer (Freescale MMA7260Q). All of the sensor’s input/output lines 
are connected to the microcontroller via jumpers. 

 
� An series of outputs: 
 

o Eight high-efficiency (low-current) LEDs together with jumpers to 
connect/disconnect them to/from the microcontroller; 
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Hardware Features 

o A piezoelectric speaker, together with a jumper to connect/disconnect it to/from 
the PTC2 pin of the microcontroller; 

o A custom LCD. 
 

� An RS-232 channel connected to the microcontroller’s SCI serial communication 
interface. The microcontroller’s PTC0/RxD and PTC1/TxD lines are used by the RS-232 
channel. 

 

 

The DEMO9S08LC60 Demonstration Board 
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3 Software Setup 

3.1 Overview 

i 
 

Note: before connecting the Demonstration Board to the PC, it is 
recommended that you install all of the required software first (see 
below), so that the appropriate USB driver will be automatically found by 
Windows when you connect the Demonstration Board. 

 
The Demonstration Board requires that both CodeWarrior Development Studio Special Edition 
and SofTec Microsystems Additional Components be installed in the host PC. 
 

i 
 

Note: CodeWarrior Development Studio for HC(S)08 must be installed 
first. 

3.2 Host System Requirements 

The Demonstration Board is controlled by CodeWarrior Development Studio. The following 
hardware and software are required to run the CodeWarrior user interface together with the 
Demonstration Board: 
 

� A 200-MHz (or higher) PC compatible system running Windows 98, Windows 2000 or 
Windows XP; 

� 128 MB of available system RAM plus 1 GB of available hard disk space; 
� A USB port; 
� CD-ROM drive for installation. 

3.3 Installing CodeWarrior Development Studio 

To install the CodeWarrior Development Studio Special Edition, insert the CodeWarrior CD-
ROM into your computer’s CD-ROM drive. A startup window will automatically appear. Follow 
the on-screen instructions. 
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3.4 Installing SofTec Microsystems Additional 
Components 

The SofTec Microsystems Additional Components install all of the other required components 
to your hard drive. These components include: 

 
� The Demonstration Board’s USB driver; 
� The software plug-in for CodeWarrior; 
� Examples; 
� Demonstration Board’s user’s manual; 
� Demonstration Board’s schematic; 
� Additional documentation. 

 
To install the SofTec Microsystems Additional Components, insert the SofTec Microsystems 
“System Software” CD-ROM into your computer’s CD-ROM drive. A startup window will 
automatically appear. Choose “Install Instrument Software” from the main menu. A list of 
available software will appear. Click on the “Additional Components” option. Follow the on-
screen instructions. 
 

i 
 

Note: to install the Additional Components on Windows 2000 or Windows 
XP, you must log in as Administrator. 
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4 Hardware Setup 

4.1 First Connection 

The Demonstration Board is connected to a host PC through a USB port. Connection steps 
are listed below in the recommended flow order: 
 
1. Install all the required system software as described in the previous section. 
2. Make sure the “POWER SEL” jumper is in the “USB” position. 
3. Insert one end of the USB cable into a free USB port. 
4. Insert the other end of the USB cable into the USB connector on the Demonstration 

Board. 
5. The first time the Demonstration Board is connected to the PC, Windows recognizes the 

instrument and starts the “Found New Hardware Wizard” procedure, asking you to 
specify the driver to use for the instrument. On Windows XP (SP2) the following dialog 
box will appear. 

 

 
 

Select the “No, not this time” option and click the “Next >” button. 
6. The following dialog box will appear. 
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Click the “Next >” button. 
7. Depending on your Windows settings, the following warning may appear. 
 

 
 

i 
 

Note: this warning is related to the fact that the USB driver used by 
the Demonstration Board is not digitally signed by Microsoft, and 
Windows considers it to be potentially malfunctioning or dangerous 
for the system. However, you can safely ignore the warning, since 
every kind of compatibility/security test has been carried out by 
SofTec Microsystems. 

 
Click the “Continue Anyway” button. 

8. Windows will install the driver files to your system. At the end of the installation, the 
following dialog box will appear. 
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Click the “Finish” button to exit from the “Found New Hardware Wizard” procedure. 
9. The Demonstration Board’s USB driver is now installed on your system. 

4.2 Power Supply 

The Demonstration Board can be powered in three ways: 
 
� 12 V DC input connector; 
� USB connector; 
� I/O header connector. 
 
The “POWER SEL” jumper allows you to power the board through either the 12 V DC input 
connector or the USB connector. 
When using the I/O header connector, its pin 1 is always connected to the 3.3 V DC line of the 
carrier board. 
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5 Operating Modes 

5.1 Overview 

The Demonstration Board can work in two modes: “standalone” mode and “host” mode. 

5.2 Standalone Mode 

In standalone mode, no PC connection is required. The microcontroller is factory programmed 
with a sample application which shows the value of the potentiometer on the display. 
To run the built-in example: 
 
1. Ensure that both the “CLK ENA” jumpers are inserted. 
2. Ensure that all of the “IO1” and “IO2” jumpers are inserted. 
3. Ensure that all of the “LED ENA” jumpers are inserted. 
4. Ensure that both the “g-Sel1” and “g-Sel2” jumpers select the “0” position. 
5. Ensure that the “Sleep Mode# SEL” jumper selects the “1” position. 
6. Ensure that the “POWER SEL” jumper selects the “USB” position. 
7. Power on the board via a USB cable. Alternatively, you can power the Demonstration 

Board through a 12 V DC plug-in power supply (not included in the kit). In this case, the 
“POWER SEL” jumper must select the “UNREG” position. 

8. The green “POWER” LED on the board should turn on. 
9. Rotate the potentiometer. Its value will be shown on the display. 

5.3 Host Mode 

In host mode the program execution is controlled by the host PC through the “USB” connector. 
You can use the PC to debug the application by, for example, executing the program step by 
step and watching how the microcontroller registers vary, using the provided CodeWarrior 
Development Studio. 
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i 
 

Note: all MCUs in the S08 family contain a single-wire background debug 
interface which supports in-circuit programming of on-chip non-volatile 
memory. This system does not interfere with normal application 
resources. It does not use any user memory or locations in the memory 
map. The Background Debug Module (also known as Background Debug 
Controller, BDC) uses a single-wire communication interface (via the 
BKGD line) to allow non-intrusive access to target system memory and 
registers. 
Please note that the BKGD line is shared with the PTC6 line and the 
RESET line is shared with the PTB2 line. The user program, therefore, 
must not use the PTC6 line when working in host mode. 

 
To work in host mode (using the built-in USB to BDM interface): 
 
� Make sure that both the “RESET#” and “BKGD” jumpers in the “IO2 ENA” jumper strips 

are inserted. 
� Make sure that the “POWER SEL” jumper is in the “USB” position. 
� Connect the host PC to the board through the provided USB cable. 
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6 Application Tutorial 

6.1 Overview 

This section will provide a step-by-step guide on how to launch your first project and get 
started with the CodeWarrior for HC(S)08 user interface. 

6.2 Step-by-Step Tutorial 

The sample application is the same as the one described in the “Standalone Mode” section 
above. 
 
1. Ensure that the Demonstration Board is connected to the PC (via the USB cable) and 

that the board is powered on. 
2. Make sure that all of the Demonstration Board jumpers are set to their factory position 

(see chapter “7.1 Jumpers” for details) 
3. Start CodeWarrior for HC(S)08 Development Studio by selecting it in the Windows Start 

menu. 
4. From the CodeWarrior main menu, choose “File > Open”. From the CodeWarrior main 

menu, choose “File > Open” and choose the “\Program Files\Freescale\CodeWarrior 
for HC08 V5.1\(CodeWarrior Examples)\HCS08\Evaluation Board 
Examples\DEMO9S08LC60\C\Demo\Demo.mcp”. 

5. Click “Open”. The Project Window will open. 
6. The C code of this example is contained in the “main.c” file. Double click on it to open 

it. 
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7. From the main menu, choose “Project > Debug”. This will compile the source code, 

generate an executable file and download it to the demo board. A new debugger 
environment will open. 
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8. From the main menu, choose “Run > Start/Continue”. The program will be executed in 

real-time. 
9. From the main menu, choose “Run > Halt”. The program execution will stop. The next 

instruction to be executed is highlighted in the Source window. 
10. From the main menu, choose “Run > Single Step”. The instruction highlighted in the 

Source window will be executed, and the program execution will be stopped immediately 
after. 

11. From the main menu, choose “Run > Start/Continue”. The application will restart from 
where it was previously stopped. 

  
Congratulations! You have successfully completed this tutorial! 
Two additional examples are provided in the “\Program Files\Freescale\CodeWarrior for 
HC08 V5.1\(CodeWarrior Examples)\HCS08\Evaluation Board 
Examples\DEMO9S08LC60\C\” directory: 
 
� Accelerometer: variation of acceleration along one of the three axis varies the output 

on the LCD and emits a sound on the speaker. 
� SCI: prints on the LCD a line of text sent by the PC through an RS-232 terminal 

application. 
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You can continue to experiment with the CodeWarrior user interface and discover by yourself 
its potentialities. For an in-depth guide of all of the user interface features, select “Help > 
CodeWarrior Help” from CodeWarrior Development Studio’s main menu.
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7 Summary of Jumper and Connector 
Settings 

7.1 Jumpers 

Name Reference Description/Pinout 

J102  

VLCD 1

VDD 

PTA0 

PTA1 

PTC3 

PTC4 

PTC5 

PTC7 
 

IO1 ENABLE 
 
Installed: The indicated microcontroller line is 

connected to the indicated user I/O 
function (default) 

Not Installed: The indicated microcontroller line is not 
connected to the indicated user I/O 
function 

J103  

PTB0 

PTB1 

 

 

CLOCK ENABLE 
 
All installed: The crystal oscillator is connected to 

the microcontroller (default) 
Not Installed: The crystal oscillator is not connected to 

the microcontroller 

J202  

1

2

3

 

 

 
 

POWER SELECTION 
 
1-2 (“UNREG”): The power supply is taken from the 

power supply connector (J201) 
2-3 (“USB”): The power supply is taken from the 

USB connector (default) 

J301  

1

2

3

 

 

 
 

PTA7 SELECTION 
 
1-2: The pin PTA7 of the microcontroller is 

connected to the pin 1 of the “LED 
ENA” jumper strip (default) 

2-3: The pin PTA7 of the microcontroller is 
connected to the NTC sensor (default) 
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Summary of Jumper and Connector Settings 

Name Reference Description/Pinout 

J302  

g-Sel2 

g-Sel1 

10  

G SELECTION 
 
Selects the accelerometer sensitivity according to the following 
table. 
 

g-Sel2 g-Sel1 Selection 

0 0 1.5 g (800 mV/g) (default) 

0 1 2.0 g (600 mV/g) 

1 0 4.0 g (300 mV/g) 

1 1 6.0 g (200 mV/g) 
 
 

J303  

1

2

3

 

 

 
 

ACCELEROMETER SLEEP MODE SELECTION 
 
1-2: Accelerometer not in sleep mode 

(default) 
2-3: Accelerometer in sleep mode 

J304  

PTA2/GX 1

PTA3/GY 

PTA4/GZ 

PTC0/RX 

PTC1/TX 

PTC2/SPK

RESET# 

BKGD 

 

IO2 ENABLE 
 
Installed: The indicated microcontroller line is 

connected to the indicated user I/O 
function (default) 

Not Installed: The indicated microcontroller line is not 
connected to the indicated user I/O 
function 

J401  

1

 

LED ENABLE 
 
Installed: The LEDs are connected to the 

microcontroller (default) 
Not Installed: The LEDs are not connected to the 

microcontroller. 
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7.2 Connectors 

Name Reference Description/Pinout 

J101  

1

14 

16 

18 

20 

22 

24 

26 

28 

3

5

7

9

11

13

15

17

19

21

23

25

27

2 

4 

6 

8 

10 

12 

30 

32 

34 

36 

38 

40 

29

31

33

35

37

39
 

40-Pin I/O Header Female Connector 
 
1. VDD  (3.3 V) 
2. PTC7 
3. GND 
4. RST# 
5. PTC1 
6. BKGD 
7. PTC0 
8. N.C. 
9. PTC4 
10. PTA0 
11. PTC5 
12. PTA1 
13. PTC2 
14. PTA2 
15. PTC3 
16. PTA3 
17. PTB5 
18. PTA4 
19. PTB4 
20. PTA5 
21. PTB6 
22. PTA6 
23. PTB7 
24. PTA7 
25. N.C. 
26. N.C. 
27. N.C. 
28. N.C. 
29. N.C. 
30. PTA2 
31. N.C. 
32. PTA3 
33. N.C. 
34. GND 
35. VDD (3.3 V) 
36. GND 
37. GND 
38. VDD (3.3 V) 
39. VLCD 
40. VDD (3.3 V) 
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Summary of Jumper and Connector Settings 

Name Reference Description/Pinout 

J104  

1

3

5

4 

6 

2 

 

BDM Connector (Not Populated) 
 
1. BKGD 
2. GND 
3. N.C. 
4. RESET/VPP 
5. N.C. 
6. VDD 

J201 
1 2

 

 

12 V DC Power Supply Input Connector 
 
1. 12 V DC 
2. Ground 

J203 

 

69 
5 1  

RS-232 Connector 
 
1. N.C. 
2. TX 
3. RX 
4. N.C. 
5. GND 
6. N.C. 
7. N.C. 
8. N.C. 
9. N.C. 

J501 

 

USB Connector 
 
1. 5 V DC USB Bus Power Supply Line 
2. USB D- 
3. USB D+ 
4. GND 
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8 Troubleshooting 

8.1 USB Driver Problems 

If you connected the Demonstration Board to the PC before installing the SofTec 
Microsystems Additional Components, the Demonstration Board’s USB driver may not have 
been correctly installed on your system. Unplugging and replugging the USB cable is of no 
use, since Windows has marked the device as “disabled”. As a consequence, the PC cannot 
communicate with the Demonstration Board. 
To restore the USB driver (provided the SofTec Microsystems Additional Components have 
been installed), perform the following steps under Windows XP: 
 
1. Connect the Demonstration Board to the PC. 
2. Open the Control Panel (Start > Settings > Control Panel). 
3. Open  the “System” options. 
4. Select the “Hardware” tab. 
5. Click the “Device Manager” button. 
6. The “uDART In-Circuit Debugger” device will be shown with an exclamation mark next 

to it. Double click on this device. 
7. In the “General” tab, click the “Reinstall Driver” button. Follow the on-screen 

instructions. 

8.2 Communication Problems between the PC and the 
Demo Board 

1. Make sure that both the “BKGD” and “RESET#” jumpers in the “IO2 ENA” jumper strip 
are inserted. 

2. Make sure that the “VDD ENA” jumper in the “IO1 ENA” jumper strip is installed. 
3. Make sure that the “POWER SEL” jumper selects the appropriate power source 

(typically “USB” when the board is connected to the PC). 
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Мы молодая и активно развивающаяся компания в области  поставок 

электронных компонентов. Мы поставляем  электронные  компоненты  

отечественного и импортного производства напрямую от производителей и с 

крупнейших складов мира. 

Благодаря сотрудничеству с мировыми поставщиками мы осуществляем 

комплексные и плановые поставки   широчайшего   спектра электронных 

компонентов. 

Собственная  эффективная  логистика и склад в обеспечивает надежную 

поставку продукции в точно указанные сроки по всей России. 

Мы осуществляем  техническую поддержку нашим клиентам и 

предпродажную проверку качества продукции. На  все поставляемые продукты 

мы предоставляем  гарантию . 

Осуществляем поставки продукции под контролем ВП МО РФ на 

предприятия военно-промышленного комплекса  России , а также работаем в 

рамках 275 ФЗ с открытием отдельных счетов в уполномоченном банке. Система 

менеджмента качества компании соответствует требованиям ГОСТ ISO 9001.  

Минимальные сроки поставки, гибкие цены, неограниченный 

ассортимент  и индивидуальный подход к клиентам являются основой для 

выстраивания долгосрочного и эффективного сотрудничества с предприятиями 

радиоэлектронной промышленности, предприятиями  ВПК и научно-

исследовательскими  институтами России. 

С нами вы становитесь  еще успешнее! 

 

 

 

 

 

Наши контакты: 

Телефон: +7 812 627 14 35 

Электронная почта: sales@st-electron.ru 

Адрес: 198099, Санкт-Петербург,  

Промышленная ул, дом № 19, литера Н,  

помещение 100-Н Офис 331 
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