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DEVELOPMENT BOARD/KIT IMPORTANT NOTICE 

 

KIONIX provides the enclosed product(s) under the following conditions: 

 
This development board/kit is intended for ENGINEERING DEVELOPMENT, DEMONSTRATION, OR EVALUATION PURPOSES 

ONLY and is not considered by KIONIX to be a finished end-product fit for general consumer use. Persons handling the product(s) 

must have electronics training and observe good engineering practice standards. As such, the goods being provided are not intended 

to be complete in terms of required design-, marketing-, and/or manufacturing-related protective considerations, including product 

safety and environmental measures typically found in end products that incorporate such semiconductor components or circuit boards. 

This development board/kit does not fall within the scope of the European Union directives regarding electromagnetic compatibility, 

restricted substances (RoHS), recycling (WEEE), FCC, CE or UL, and therefore may not meet the technical requirements of these 

directives or other related directives. 

 

Kionix warrants that the development board/kit sold will, upon shipment, be free of defects in materials and workmanship under 
normal and proper usage. This warranty shall expire 30 days from date of shipment. Kionix will repair or replace, at Kionix’s discretion, 

any defective goods upon prompt written notice from the Customer within the warranty period. Such repair or replacement shall 

constitute fulfillment of all liabilities of Kionix with respect to warranty and shall constitute Customer’s exclusive remedy for defective 

goods. 

 

The user assumes all responsibility and liability for proper and safe handling of the goods. Further, the user indemnifies KIONIX from 

all claims arising from the handling or use of the goods. Due to the open construction of the product, it is the user’s responsibility to 

take any and all appropriate precautions with regard to electrostatic discharge. 

 
IT IS HEREBY EXPRESSLY AGREED THAT KIONIX MAKES AND CUSTOMER RECEIVES NO OTHER WARRANTY, EXPRESS OR IMPLIED, 

THAT ALL WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE EXPRESSLY EXCLUDED, AND THAT 

KIONIX SHALL HAVE NO LIABILITY UNDER ANY CIRCUMSTANCES FOR CONSEQUENTIAL, INCIDENTAL OR EXEMPLARY DAMAGES 

ARISING IN ANY WAY FROM THE MISUSE OF ITS PRODUCTS.  

 

KIONIX assumes no liability for applications assistance, customer product design, software performance, or infringement 

of patents or services described herein. 

 

No license is granted under any patent right or other intellectual property right of KIONIX covering or relating to any machine, process, 

or combination in which such KIONIX products or services might be or are used. 

 

FCC Warning 
 

This development board/kit is intended for ENGINEERING DEVELOPMENT, DEMONSTRATION, OR EVALUATION PURPOSES 

ONLY and is not considered by KIONIX to be a finished end-product fit for general consumer use. It generates, uses, and can radiate 

radio frequency energy and has not been tested for compliance with the limits of computing devices pursuant to part 15 of FCC rules, 

which are designed to provide reasonable protection against radio frequency interference. Operation of this equipment in other 
environments may cause interference with radio communications, in which case the user at his own expense will be required to take 

whatever measures may be required to correct this interference. 

 

 

 

 

“Texas Instruments” and “TI” are registered trademarks of Texas Instruments Incorporated, a Delaware corporation, having its 

registered address at: 12500 TI Boulevard, Dallas, Texas 75243, USA.  
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Contents 
 
1. Kionix EZ430-C9 Evaluation board 

2. CD containing sample firmware for reading acceleration 
3. Application Note AN053 (this document) 

 

Overview 
 
The Texas Instruments (TI) eZ430-F2013 development kit with the Kionix KXTC9 

Evaluation Board (EZ430-C9) provides a simple environment to quickly start 

sampling X, Y, and Z accelerations and create accelerometer applications using the 

MSP430F2012 in a convenient USB form factor.  

 

Hardware 
 

Development Kit Components  
 

Texas Instrument eZ430-F2013 (not included) 
 
TI’s eZ430 Development Tool consists of a MSP-EZ430U Debugging Interface, which 

connects to a detachable eZ430-T2012 target board all housed inside a plastic 

enclosure. The enclosure can be opened to attach/detach different target boards. It 

is to the eZ430-T2012 target board that the Kionix accelerometer evaluation board 

can be attached.   

 

 

Figure 1: eZ430-F2013 Development Tool 
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The MSP-EZ430U debugging interface may come with Spy Bi-Wire Interfaces supplied 

through either a 4-pin connector (Figure 2) or a 6-pin connector (Figure 3). 

 

Figure 2: eZ430-F2013 development kit with 4-pin target board connector 

 

Figure 3: eZ430-F2013 development kit with 4-pin target board connector 

Since the detachable eZ430-T2012 target board comes with a 4-pin connector, it 

should be placed on the middle 4-pins of the eZ430-F2013 development kit if it comes 

with 6-pin connector. 

 

The eZ430 Development Tool provides a real-time debugging and programming 

interface for the MSP430F2012 on the target board, and comes with the easy-to-use 

IAR Embedded Workbench Integrated Development Environment (IDE). The T2012 

can be used to develop your personal project or to evaluate the MSP430 MCU. The 

latest product information and ordering information about the ez430 Development 

Tool can be found at: http://www.ti.com/tool/ez430-f2013. The latest product 

information and ordering information about the eZ430-T2012 target board can be 

found at: http://www.ti.com/tool/ez430-t2012. 

http://www.ti.com/tool/ez430-f2013
http://www.ti.com/tool/ez430-t2012
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Kionix EZ430-C9 Evaluation Board 
 
The Kionix EZ430-C9 Evaluation Board provides the connection between the KXTC9-

2050 accelerometer and the MCU. The two boards (Kionix EZ430-C9 and the TI 

eZ430-T2012 target board) connect to each other through the 14-pin configuration 

(Figure 4). The pin configuration of both boards are compatible with each other, 

meaning pin 1 through pin 14 of the eZ430-T2012 connect to pin 1 through pin 14 

of the EZ430-C9 respectively.  

 

 

Figure 4: Kionix EZ430-7 Evaluation Board Mounted on TI eZ430-T2012 

 

Power to the EZ430-C9 is provided through the target board. If the target board 

along with the EZ430-C9 is to function as a standalone unit, then an external power 

supply can be connected appropriately to the 14-pin connection.  
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PCB board schematic is shown in Figure 5, and board layout, pin description, and 
accelerometer axis orientation are shown in Figure 6.  

 

 
Figure 5: Schematic for EZ430-C9 Evaluation Board 

 

 
 Outer Dimensions: 1.9cm x 1.6cm 

 
Figure 6: PCB Layout, Part Orientation, and J1 Connector Pin Description 

 
 

J1 Connector Pin 

Description 

pin 1 VDD 

pin 2 GND 

pin 3 P2 

pin 4 P13 

pin 5 P3 

pin 6 P12 

pin 7 P4 

pin 8 P11 

pin 9 P5 

pin 10 P10 

pin 11 X 

pin 12 P9 

pin 13 Y 

pin 14 Z 
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The product specifications for the KXTC9-2050 accelerometer can be found at: 

http://www.kionix.com/product/KXTC9-2050 

 

 

Software 
 

Getting Started 
 

Install the IAR Workbench. The IDE can be obtained from TI’s website. 

http://www.ti.com/tool/iar-kickstart. More information about the IDE is available on 

the website as well.  

 

Reading Acceleration Data Demo 
 

A sample C file has been provided to help you get started in reading X, Y, and Z 

acceleration data. You will need to set up a project for the eZ430-T2012, and 

download the application onto the MSP430F2012. The following steps will guide you 

through the process: 

 

1. Start the Workbench. (Start -> All Programs -> IAR Systems -> IAR Embedded 

Workbench for MSP430 6.30 -> IAR Embedded Workbench). 

 

2. Click on the File tab -> Open Workspace ->. Select the directory where you 

have unzipped the ‘AccelDemoKXTC9.zip’.  

 

3. Select the ‘KXTC9_F2012.eww’ workspace. 

 

4. Set the correct device by clicking on Projects -> Options -> General Options –

select ‘Target’ tab and select MSP430F2012 from the list (Figure 4). 

http://www.kionix.com/product/KXTC9-2050
http://www.ti.com/tool/iar-kickstart
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Figure 7: Select MSP430F2012 Device 

5. Still in the Options window, select ‘Debugger’ category, select ‘Setup’ tab, and 

choose FET Debugger under Driver window (Figure 8). 

 

Figure 8: Select FET Debugger 
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6. Still in the Options window, under ‘Debugger’ category, select ‘FET Debugger’ 

sub-category, select ‘Setup’ tab, and choose ‘Texas Instrument USB-IF’ in the 

‘Connection’ window to use the USB interface (Figure 9). 

 

Figure 9: Select Texas Instrument USB-IF Connection Type 

7. Use Project -> Rebuild All to build and link the source code. You can view the 

source code by double clicking on the project, and then double-clicking on the 

displayed source file.  

 

8. Use Project -> Download and Debug to start the C-SPY debugger. C-SPY will 

erase the device Flash, and then download the application object file to the 

device Flash.  
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9. Place the cursor on the Zout variable. Press Run to cursor button to refresh 

the view of the Xout, Yout, and Zout (X, Y, and Z acceleration) variables in the 

watch window (Figure 10).  

 

Figure 10: Operation in Debug Mode 

 

Congratulations, you have successfully built and tested the AccelDemoKXTC9 

application  
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Technical Support 
 
If you experience technical difficulties with the EZ430-C9 evaluation board, please 

contact your local Kionix Sales Office for technical support information. 

 
 

The Kionix Advantage  
 
Kionix technology provides for X, Y, and Z-axis sensing on a single, silicon chip. One 

accelerometer can be used to enable a variety of simultaneous features including, 
but not limited to:  

 
Hard Disk Drive protection  
Vibration analysis  

Tilt screen navigation  
Sports modeling  

Theft, man-down, accident alarm  
Image stability, screen orientation & scrolling  
Computer pointer  

Navigation, mapping  
Game playing  

Automatic sleep mode  
 

Theory of Operation  
 
Kionix MEMS linear tri-axis accelerometers function on the principle of differential 

capacitance. Acceleration causes displacement of a silicon structure resulting in a 
change in capacitance. A signal-conditioning CMOS technology ASIC detects and 

transforms changes in capacitance into an analog output voltage, which is 
proportional to acceleration. These outputs can then be sent to a micro-controller for 
integration into various applications. For product summaries, specifications, and 

schematics, please refer to the Kionix MEMS accelerometer product catalog at: 
http://www.kionix.com/parametric/Accelerometers 

http://www.kionix.com/parametric/Accelerometers


 

 

 

Мы молодая и активно развивающаяся компания в области  поставок 

электронных компонентов. Мы поставляем  электронные  компоненты  

отечественного и импортного производства напрямую от производителей и с 

крупнейших складов мира. 

Благодаря сотрудничеству с мировыми поставщиками мы осуществляем 

комплексные и плановые поставки   широчайшего   спектра электронных 

компонентов. 

Собственная  эффективная  логистика и склад в обеспечивает надежную 

поставку продукции в точно указанные сроки по всей России. 

Мы осуществляем  техническую поддержку нашим клиентам и 

предпродажную проверку качества продукции. На  все поставляемые продукты 

мы предоставляем  гарантию . 

Осуществляем поставки продукции под контролем ВП МО РФ на 

предприятия военно-промышленного комплекса  России , а также работаем в 

рамках 275 ФЗ с открытием отдельных счетов в уполномоченном банке. Система 

менеджмента качества компании соответствует требованиям ГОСТ ISO 9001.  

Минимальные сроки поставки, гибкие цены, неограниченный 

ассортимент  и индивидуальный подход к клиентам являются основой для 

выстраивания долгосрочного и эффективного сотрудничества с предприятиями 

радиоэлектронной промышленности, предприятиями  ВПК и научно-

исследовательскими  институтами России. 

С нами вы становитесь  еще успешнее! 

 

 

 

 

 

Наши контакты: 

Телефон: +7 812 627 14 35 

Электронная почта: sales@st-electron.ru 

Адрес: 198099, Санкт-Петербург,  

Промышленная ул, дом № 19, литера Н,  

помещение 100-Н Офис 331 

mailto:sales@st-electron.ru

