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Object of Declaration: EMC1182 Temperature Sensor Evaluation Board User’s Guide

EU Declaration of Conformity

This declaration of conformity is issued by the manufacturer.

The development/evaluation tool is designed to be used for research and development in a laboratory
environment. This development/evaluation tool is not a Finished Appliance, nor is it intended for
incorporation into Finished Appliances that are made commercially available as single functional units to
end users under EU EMC Directive 2004/108/EC and as supported by the European Commission’s Guide
for the EMC Directive 2004/108/EC (8" February 2010).

This development/evaluation tool complies with EU RoHS2 Directive 2011/65/EU.

For information regarding the exclusive, limited warranties applicable to Microchip products, please see
Microchip’s standard terms and conditions of sale, which are printed on our sales documentation and
available at www.microchip.com.

Signed for and on behalf of Microchip Technology Inc. at Chandler, Arizona, USA

Q&MM _Lé_-_gﬁg%c;éﬂj,
Derek Carlson Date

VP Development Tools
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EMC1182
TEMPERATURE SENSOR

MICROCHIP EVALUATION BOARD

Preface

NOTICE TO CUSTOMERS

document.

All documentation becomes dated, and this manual is no exception. Microchip tools and
documentation are constantly evolving to meet customer needs, so some actual dialogs
and/or tool descriptions may differ from those in this document. Please refer to our web site
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each
page, in front of the page number. The numbering convention for the DS number is
“DSXXXXXA”, where “XXXXX” is the document number and “A” is the revision level of the

For the most up-to-date information on development tools, see the MPLAB® IDE online help.
Select the Help menu, and then Topics to open a list of available online help files.

INTRODUCTION

This chapter contains general information that will be useful to know before using the
EMC1182 Temperature Sensor Evaluation Board. Items discussed in this chapter
include:

Document Layout

Conventions Used in this Guide
Recommended Reading

The Microchip Web Site
Customer Support

Document Revision History

DOCUMENT LAYOUT

This document describes how to use the EMC1182 Temperature Sensor Evaluation
Board as a development tool to emulate and debug firmware on a target board. The
manual layout is as follows:

Chapter 1. “Product Overview” — Important information about the EMC1182
Temperature Sensor Evaluation Board.

Chapter 2. “Installation and Operation” — Includes instructions on installing and
starting the SMSC™ Chip Manager application.

Chapter 3. “Hardware Description” — Shows hardware details of the EMC1182
Temperature Sensor Evaluation Board.

Chapter 4. “Software Description” — Describes the main operations in the
SMSC Chip Manager software.

Appendix A. “Schematic and Layouts” — Shows the schematic and layout
diagrams for the EMC1182 Temperature Sensor Evaluation Board.

Appendix B. “Bill of Materials (BOM)” — Lists the parts used to build the
EMC1182 Temperature Sensor Evaluation Board.

© 2013 Microchip Technology Inc. DS50002189A-page 7
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description

| Represents

Examples

Arial font:

Italic characters

Referenced books

MPLAB® IDE User’s Guide

Emphasized text

...Is the only compiler...

Initial caps A window the Output window
A dialog the Settings dialog
A menu selection select Enable Programmer
Quotes A field name in a window or | “Save project before build”
dialog
Underlined, italic text with A menu path File>Save
right angle bracket
Bold characters A dialog button Click OK

A tab

Click the Power tab

N‘Rnnnn

A number in verilog format,
where N is the total number of
digits, Ris theradix and n is a
digit.

4'b0010, 2'hF1

Text in angle brackets < >

A key on the keyboard

Press <Enter>, <F1>

Courier New font:

Plain Courier New

Sample source code

#define START

Filenames autoexec.bat

File paths c:\mccl18\h

Keywords _asm, _endasm, static
Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants O0xFF, ‘A’

Italic Courier New

A variable argument

file.o, where file can be
any valid filename

Square brackets [ ]

Optional arguments

mccl8 [options] file

[options]

Curly brackets and pipe
character: { | }

Choice of mutually exclusive
arguments; an OR selection

errorlevel {0]1}

Ellipses...

Replaces repeated text

var name [,
var name...]

Represents code supplied by
user

void main (void)

{
}

DS50002189A-page 8

© 2013 Microchip Technology Inc.



Preface

RECOMMENDED READING

This user's guide describes how to use the EMC1182 Temperature Sensor Evaluation
Board. Another useful document is listed below. The following Microchip document is
available and recommended as a supplemental reference resource.

« EMC1182 Data Sheet — “Dual Channel 1.8V SMBus/I>C Temperature Sensor
with Resistance Error Correction, Beta Compensation”
(EMC1182 DS Rev. 1.0)

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This web
site is used as a means to make files and information easily available to customers.
Accessible by using your favorite Internet browser, the web site contains the following
information:

* Product Support — Data sheets and errata, application notes and sample
programs, design resources, user’s guides and hardware support documents,
latest software releases and archived software

* General Technical Support — Frequently Asked Questions (FAQs), technical
support requests, online discussion groups, Microchip consultant program
member listing

» Business of Microchip — Product selector and ordering guides, latest Microchip
press releases, listing of seminars and events, listings of Microchip sales offices,
distributors and factory representatives

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

+ Distributor or Representative

* Local Sales Office

* Field Application Engineer (FAE)
 Technical Support

Customers should contact their distributor, representative or field application engineer
(FAE) for support. Local sales offices are also available to help customers. A listing of
sales offices and locations is included in the back of this document.

Technical support is available through the web site at:
http://www.microchip.com/support.

DOCUMENT REVISION HISTORY
Revision A (August 2013)

« Initial Release of this Document.

© 2013 Microchip Technology Inc. DS50002189A-page 9
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MICROCHIP

EMC1182 TEMPERATURE
SENSOR EVALUATION
BOARD USER’S GUIDE

Chapter 1. Product Overview

INTRODUCTION

The EMC1182 Temperature Sensor Evaluation Board provides an easily accessible
platform to test the various features of the EMC1182. The System Management Bus
(SMBus) communication is accomplished using an Universal Serial Bus (USB) bridge,
providing a standard interface for the application code interface. The board is popu-
lated with a 3x3 DFN version of the EMC1182 device.

EMC1182 DEVICE FEATURES

The EMC1182 device is a two-channel SMBus temperature sensor featuring both
pin-selectable and fixed SMBus address capability. The communications bus is also
compatible with [2C communication protocol (see SMSC® application note AN 14.0
rev.1.1- “SMSC Dedicated Slave Devices in [°C Systems”for details on the differences
between the SMSC SMBus implementation and standard IZC/SMBus).

One externally connected temperature diode and one internal diode are available for
temperature sensing. THERM and ALERT outputs have programmable temperature
limits.

WHAT IS THE EMC1182 TEMPERATURE SENSOR EVALUATION BOARD?

All functions of the EMC1182 device can be tested and observed using the USB-based
EMC1182 Temperature Sensor Evaluation Board. Figure 1-1 shows the block diagram
of this board.

USB
Connector
A
v
USB to SMBus
Bridge
SMBus SMBus ALERTH
Connector
ALERT#
©
Address »| EMC1182
Select
8LD 3x3 REC
DFN @ EXT DIODE 1
EXT DIODE 1
Temperature
Monitor

FIGURE 1-1: EMC1182 Temperature Sensor Evaluation Board Block Diagram.

© 2013 Microchip Technology Inc.
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The evaluation system is comprised of the EMC1182 Temperature Sensor Evaluation
Board and the SMSC Chip Manager application. The EMC1182 Temperature Sensor
Evaluation Board has the following features:

» Headers for connecting an external diode or CPU/GPU

» Resistance Error Correction verification

» USB-to-SMBus bridge for power and communications

+ Capability to connect directly to an external SMBus master

The user can perform the following operations using the Chip Manager:

» Viewing and changing register values

» Saving settings of all registers, allowing for quick configuration at a later time

» Graphing of any register

The evaluation board was designed for ease of use and experimentation purposes.
Figure 1-2 shows the top silk screen of the EMC1182 Temperature Sensor Evaluation
Board.

SMBus\Jumper Remote Diode
ADM000516 M4 16
Ll — 1l 2 RTJ3 B 3
uUse |, P F r rl A D |
Connector DU — M 1p2 [ — a -~
%[ng:ugg ,33\/ 5 J2 RED R4 c
N R pLert ] e
EMC1182
FIGURE 1-2: EMC1182 Temperature Sensor Evaluation Board Top Silk Screen.
1.4 WHAT THE EMC1182 TEMPERATURE SENSOR EVALUATION BOARD KIT

CONTAINS

This EMC1182 Temperature Sensor Evaluation Board kit includes:
+ EMC1182 Temperature Sensor Evaluation Board (ADM00516)

» Supplied USB cable

* Important Information Sheet

DS50002189A-page 12
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Chapter 2. Installation and Operation

21 GETTING STARTED

211 System Requirements

To use the EMC1182 Temperature Sensor Evaluation Board, the following are required:

* A PC running the Microsoft® Windows® operating system

+ A display resolution of 800x600 or larger, for viewing several windows
simultaneously

* An available USB port

21.2 Installing the Evaluation Board

Follow the next steps to install the SMSC Chip Manager.

1. Download the ChipMan. zip file from the board web page. Unzip the archive.
The application’s revision history and install/uninstall notes may be found in the
readme. txt file.

2. To install the Chip Manager application and the device driver on the PC, run the
Setup.exe.

3. Connect the supplied USB cable to an available USB port on the PC. Plug the
mini-B end of the USB cable into the board connector P3. The +3.3V and the
Bridge ACT LEDs should illuminate.

4. If the USB Bridge driver has not previously been installed on the selected USB
port, the Driver Software Installation window pops up, prompting for the driver
install (see Figure 2-1).

W Driver Software Installation X|

Installing device driver software

SMISC LISB Bridge «_¥Searching Windows Update...

Obtaining device driver software from Windows Update might take a while.
Skip obtaining driver software from Windows Update

.

W Driver Software Installation il
SMSC USB Bridge installed
SMSC LUSE Bridge J Ready to use
FIGURE 2-1: Device Driver Load and Complete.

© 2013 Microchip Technology Inc. DS50002189A-page 13
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5. After the driver installation is complete, the initial setup screen for the Chip
Manager application appears (see Figure 2-2). Click Next to start the installation.

SMSC Chip Manager Setup ver 4.16.4 X|
Welcome to the InstallShield Wizard for ChipMan

The InstallShield®\izard will install Chipkdan on your
computer. To continue, click MNext.

< Back | et » [ ! Cancel

FIGURE 2-2: InstallShield Wizard Startup Window.

6. Read and accept the licensing agreement, in order to complete the installation.
To continue, click Yes.

SMSC Chip Manager Setup ver <4.16.4

License Agreement

Flease read the following license agreement carefully.

I~
Fress the PAGE DOWYMN key to see the rest of the agreement. b

EMSC SOFTWARE LICENSE AGREEMENT (OEM / IHY {15 Distribution & Single User) il

IMPORTANT - READ BEFORE COPYING, INSTALLING OR LISIMNG.

Do not use or load this software and any associated materials (collectively. the "Software") until
wou hawve carefully read the following terms and conditions. By loading ar using the Software, vou
agree to the terms of this Agreement. If wou do notwish to so agree. do not install or use the

Software.
Flease Also MNote:
“If vou are an Original Equipment tanufacturer (OEM]. Independent Hardware Yendar (IHY). ar _I

-

Do wou accept all the terms of the preceding License Agreement? If you select Mo, = |
the setup will close. To install Chipkdan, wou must accept this agreement.

InstallSheld

< Back Yes Mo |

FIGURE 2-3: License Agreement Dialog.

DS50002189A-page 14 © 2013 Microchip Technology Inc.
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7. On the Choose Destination Location dialog, browse for the desired location, or
click Next to install in the default location (see Figure 2-4). The application setup
window appears, showing the installation progress (see Figure 2-5).

SMSC Chip Manager Setup ver 4.16.4 il

Choose Destination Location ‘ i
.":M

Select folder where setup will install files.

Setup will install Chipkdan in the following folder.

l Ta install to this falder, click MNext. To install to & different folder, click Browse and selectanather
folder.

Destination Folder

ChProgram Files (x86)\SMM3C\Chiphan Browse... |

InstallEheld

FIGURE 2-4: Destination Path Dialog.

SMSC Chip Manager Setup ver 4.16.4 il

Setup Status { i

Chiphdan is configuring wour new software installation.

IhstallShield

Cancel

FIGURE 2-5: Setup Progress Window.

© 2013 Microchip Technology Inc. DS50002189A-page 15
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8. After the setup is complete, the MSXML Parser used by the Chip Manager
software is installed, as shown in Figure 2-6. Once the setup completes
successfully, press Finish to exit the install.

{i§ MSXML 6.0 Parser Setup x|

. Completing the MSXML 6.0 Parser Setup

Setup has installed MSXML 6.0 Parser successfully, Click Finish to
exit,

= Back ” Finish '\J Cancel |
| 5%

FIGURE 2-6: MSXML Parser Install Window.

9. Start the software by either going to Windows Start button > All Programs >
SMSC > SMSC Chip Manager or by double-clicking the software icon (gp) on
the desktop. The evaluation board software will initialize and the SMSC Chip
Manager with the Quick Help screen appears (see Figure 2-7).

=T

File View Options Control Help

K]

Quick Help:

The purpose of this utility is to allow the user to view and edit SMSC
device registers in the Windows environment

To view a group of registers, select the appropriate group in the left pane
To editthe value of a register. double click the value in the "Last value"
colurn in the right upper pane. Type in the desired value. The register
will be updated with the newvalue once the cursar leaves the edit window.
Read only registers are denoted by "R" in the "RAN" column and editing
ofthese register values is disallowed.

Some registers have hitfield definitions. They are displayed in the lower

right pane. If the register is not read only (i.e. readwrite) the value of each

field can be edited by double clicking on the field value in the "LastWalue"

colurmn of this pane. Type inthe desired value to update the hit(s) of the register.
The field may also be changed by making a selection from the field's drog down list
It & drop down listis available for this field, a combo box stde button will appear
atthe right of the "Translation” column. Clicking the button will allow you to select

a setting for the hitfield from a drop down list

The currentwalues of the registers can be sawved 1o an extemnal text file by
using the Export feature. The saved textfile can also be read back to the
device by using the Importfeature. Import only affects readfwrite registers

Dbl click walue in Last Walue column to edit | A

FIGURE 2-7: SMSC Chip Manager with Quick Help Window.

DS50002189A-page 16 © 2013 Microchip Technology Inc.
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10. If a message stating that no device has been selected appears, click Yes to
select a device. Alternatively, go to the Chip Manager’s main menu, select
Options > Select Device. In either case, the Select SMSC Device window dis-
plays, as shown in Figure 2-8.

In the “SMSC Device” list, choose EMC1182. From the “Master Controller”
drop-down list choose “SMBus USB-SMB-SPI Bridge”. Click OK to complete the
device selection.

SMSC Chip Manager X| Select SMSC Device X|

Device | Remote |

SMSC Device: IEMC'HBZ LI

— LPC Bus Settings

Catfiguration Address: I [V Select automatically

Mo SMSC device has been selected
Would you like to select a device?

— ShiBus Settings

Slave Addresses: | Biocl I Registers | Slave Address
Hidh 0zZ:FF a8

[~ Select automatically

Master Contraller. |ShsC USB-SMB-5PI Bridg |

/0 Controller Hulb |
LUSE SkBus Bridge

Pl Bridge

[~ Simulation Mode

OFK. I Cancel

FIGURE 2-8: Select SMSC Device Window.

© 2013 Microchip Technology Inc. DS50002189A-page 17
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11. From the Chip Manager main menu, ensure that Options > Auto refresh
Registers is checked. In the left panel, click the hardware monitor (HWM) to
expand the content, then select any of the register groups, as shown in
Figure 2-9. The USB Activity LED on the board starts blinking when any of the
register groups are selected. The register values are automatically updated
every second when the Auto Refresh option is on.

SMSC Chip Manager - SMSC Confidential - ol x|
Fle Wiew OCptions Confral Help
6 P
=-E@ EMC1182 Register Mame | Address | R | Last ¥al... | Units | Abbreviation | Bus Type
Internal Temp 00,29 R FF Degrees(C) TLAM SMBUS
: Status External Diode Temp 01,10 R FF Degrees(C) TLD1 SMBUS
: Configuration Internal Temperature High Limit 05 R FF Degrees{C) TALH SMBLS
- Legacy Mode TemperatLires Internal Temperature Low Limit 06 Ry FF Degrees(C) TALL SMBUS
: Extended Mode TemperatLires Internal THERM Limit 20 R FF Degrees(C) THAL SMBUS
- Device Info External Temperature High Limit 07,13 R FF Degrees{C) TiH SMBUS
' External Temperature Low Limit 03,14 R FF DegreesiC) TILL SMBUS
External THERM Limit 19 R FF Degrees(C) THIL SMBUS
THERM Hysteresis 21 R FF Degrees{C) THH SMBUS
< | i
Bit Field Mame | Bit{s) | Last Walue | Translation |
Dbl click value in Last Value column to edit [Block HWM / Group 2 : Legacy Mode Temperatures v
FIGURE 2-9: Chip Manager Register Groups.

DS50002189A-page 18 © 2013 Microchip Technology Inc.
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Chapter 3. Hardware Description

3.1  INTRODUCTION

The EMC1182 Temperature Sensor Evaluation Board provides the means to
demonstrate all of the EMC1182 features, and allows the registers to be viewed and
modified. LEDs indicating status information and test points are included to enable
system voltage monitoring, using a voltmeter or an oscilloscope.

3.1.1 Power Source

The board requires only one universal serial bus (USB) connection to power the board.
The USB-to-SMBus bridge regulates the +5V USB power to +3.3V used by the
EMC1182 and other evaluation board circuitry.

3.2 USB-TO-SMBUS BRIDGE

The USB-to-SMBus bridge is based on an 8-bit microcontroller with integrated USB
and SMBus interfaces, as well as internal flash and RAM. During the evaluation board
manufacturing process, the firmware is loaded into the bridge that provides the inter-
face between the USB and the SMBus. Power is sourced to the microcontroller from
the USB interface for device power and communication.

3.21 Direct SMBus Connect Option

It is also possible to connect an external SMBus master to the EMC1182 Temperature
Sensor Evaluation Board. A few jumper settings are required to drive the EMC1182 on
the evaluation board, as explained in the following steps:

* Remove the jumpers on header JP10 and connect the SMBus master to the SDA,
SCL and ALERT pins (3, 5 and 7, respectively), as well as an external supply for
+3.3V (pin 1).

* Remove resistors R19, R20, R22 and R25, shown in Figure 3-1.

» The +3.3V can be supplied by the SMBus bridge by leaving the +3.3V jumper in
place and retaining the USB connection.

3.2.2 Supplemental 1.8V SMBus Pull-up

A 1.8V (nominal) linear regulator is placed on the board along with the jumpers to
connect SDA and SCL to a 1.8V pull-up supply. Once the jumper resistors are
disconnected, jumpers connecting J2-1 to J2-2 and J2-3 to J2-4 may be installed to
activate the 1.8V pull-ups. This jumper is identified in Figure 3-1 by the blue circle.

© 2013 Microchip Technology Inc. DS50002189A-page 19
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Remove resistors for
Direct SMBus Connect

BRIDGE

e 'Y

USB _»3.3V

Feifer] ~'

Bl |||

Jumpers connection for
1.8V pull-up activation

)

F—

C8

WL e
con ® mms[l_:ﬂ = =
m»n Lo ‘ms[l_: )
vy
O MMM 24
wl
FIGURE 3-1: SMBus Jumper Resistors.
3.3 RESISTANCE ERROR CORRECTION (REC)

The external diode 1 (Q1) on the board has a series resistance adjustment on the DN
line. Checking the Resistance Error Correction (REC) feature is accomplished by
turning the resistor wheel R5. With the REC on, the temperature will not change as the
wheel is turned. With REC off, a significant temperature error will occur.

3.4 TEST POINTS
The EMC1182 Temperature Sensor Evaluation Board includes test points for the
following:
» ALERT output (TP1)
+ THERM output (TP2)
3.5 LED INDICATORS
Table 3-1 details the LEDs status of the following signals:
TABLE 3-1: LED STATUS INDICATORS
LED No. Signal When LED is OFF When LED is ON Color
LED1 ALERT +3.3V power OFF ALERT red
LED3 +3.3V +3.3V power OFF +3.3V power ON green
LED4 Bridge Activity NO Activity on USB/SMBus Bridge Activity on USB/SMBus Bridge green
LED5 USB Activity NO Activity on USB port Activity on USB port green
DS50002189A-page 20 © 2013 Microchip Technology Inc.
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3.6 REMOTE DIODES

The evaluation board is populated with jumpers
off-board diode (see Table 3-2).

to connect to the on-board diode or an

To connect to an off-board CPU or GPU, remove both jumpers from header J1. Then
connect Pin 1 to the ‘remote+’ terminal of the off-board diode and Pin 2 to the ‘remote—’
terminal of the off-board diode. Make sure a common ground exists between the
off-board diode (GPU, etc.) and the evaluation board. Ensure that the off-board diode
is properly biased. Consult the CPU manufacturer’s data sheet for guidance on
interfacing to the thermal diode. Refer to the EMC1182 Temperature Sensor Evaluation
Board schematic in Appendix A. “Schematic and Layouts” for details on the

evaluation board header connections.

TABLE 3-2: REMOTE DIODE CONFIGURATIONS
Jumper Configuration Pin 1 ‘ Pin 2 Pin 3 ‘ Pin 4
J1 On-board diode (Q1) short/DP short/DN
General purpose remote diode open ‘ remote+/DP open ‘ remote—/DN
CPU/GPU diode good common ground

3.7 OTHER SENSOR FEATURES

Other features, such as Conversion Rate, Dynamic Averaging and Digital Filtering, can
be controlled with the EMC1182 registers. Refer to the device data sheet for details on

the register description.

© 2013 Microchip Technology Inc.
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NOTES:
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Chapter 4. Software Description

41 CHIP MANAGER APPLICATION OVERVIEW

The Chip Manager application enables the user to display temperature readings, set
temperature limits and read/write configuration register values. The Chip Manager
initially displays a Quick Help screen (see Figure 2-7). For detailed information on
application features and usage, select Help > Contents to display the HTML-based
Help document, as shown in Figure 4-1.

(’_" Ci'Program Files (x86)'8MSC" ChipMan'y
f/_‘- -'-"\__
|.\ .II

10| x|

@€ | C\Program Files (xB6NST j 5 K I Bing pe

| Fle Edit view Favorites Tooks Help

L Favorites &2 C:\Program Files (x861SMSCChipMani... ‘ ‘

SMSC Chip Manager
Contents

Device Selection

Regzister Control

Saving and Restoring Register Settings
Plotting Register Data

Capture Register Data to a File
Hardware Monitor Register Configuration
Debugeing I'O Registers

Connecting to a Device on a Remote Host
Siumulation Mode

Thermal Mode

Fan Cwrve Test

SMBug Test

Command Line Optiong

r|—|—|[m Computer | Protected Modea: Off | Al | H125% ¥

FIGURE 4-1: Chip Manager Help Screen.

411

Real-Time Register Graphs

The Chip Manager software has the ability to plot register values in real-time, up to a
10 Hz continuous rate.

© 2013 Microchip Technology Inc.
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41.2

Selecting Registers to Plot

1. To plot a register, right-click the desired register name or value. Select the “Add
Register(s) to Plot” from the context menu (see Figure 4-2), to add the register
or value to the plot list.

SMSC Chip Manager - SMSC Confidential

File ‘“iew Opfions Control Help

=1olx]

S H B P

=B EMC11582

: Status
: Configuration

¥ 4 : Device Info

4 |

1 Legacy Mode Tempers
1 Extended Made Tempe

||

Cbl click walue in Last Yalue column to edit

Register Wame
[ntermal Temp

RAM | Last wal.., Abbreviation | Bus Type
TLAM SMBUS

SMBUS

ot

External Diode Temp 0 Flot LDl
Internal Temperature High Limit 05 Ry Degrees(C) TALH SMBUS
Internal Temperature Low Limit 06 R FF Degrees(C) TALL SMBUS
Iritermal THERM Limit 20 R FF Degrees(C) THAL SMBLUS
External Temperature High Limit 07,13 R FF Degrees(C) TiH SMBUS
External Temperature Low Limit 03,14 R FF Degrees(C) TIL SMBLIS
External THERM Limit 19 Ry FF Degrees(C) THIL SMBUS
THERM Hysteresis 21 R FF Degrees(C) THH SMBEUS
< | i
Bit Field Name | Bit(s) | Last Yalue | Translation |
[Block HwM / Group 2 : Legacy Mode Temperatiires 4

FIGURE 4-2:

Adding Registers to Plot.

2. Once the desired register is added to be plotted, a graphic plot window will
appear with a legend on top, as shown in Figure 4-3. The two windows can be
rearranged independently.

File  Options

[l Temperature (°C)

Wigw  Control

=8|

:l flzz

120+

a0+

B0+

-304-

-B0--

904

-120+

Temperat

E

Block IAddr.. | Namel Flot line typel

Hi'hd 00 Interna

H EF

—————————————
time (sec)

Time perdivisiun.lm 5 vl

FIGURE 4-3:

Register Plot Window.

3. To plot additional registers, go back to the Chip Manager main window and

repeat Step 1.
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41.3

Starting the Plots

All plots can be started simultaneously by selecting Control > Plots > Start All Plots from
the menu, in the main application window. Multiple plots will be in sync if they are
started simultaneously.

Individual plots may be paused at any time by clicking Control > Pause in the plot
window. This will not cause loss of captured data on the other plot windows.

For a better view on the plot, select a different “Time per division” value in the

drop-down menu at the bottom of the plotting window. This scale change affects both
the real-time mode and the playback mode, while the rate at which data is recorded is
unaffected.

41.4

Sampling a Plot

Figure 4-4 is an example of temperature history. Internal Temperature, External
Diode 1 Temperature and External Diode 1 High Limit are selected for plotting. The
results after the plot starting are that the External Diode Temperature High Limit is
reduced, the External diode 1 starts at room temperature and is then heated by simply
placing a finger on the external diode Q1.

Temperature (°C) Legend ﬂ
Block Address MNarme Plotline type I
Hidvhd 00.29 Internal Termp
Hivhd 0110 External Diode Temp
Hih 07.13 External Temperature High Limit
Bl Temperature (°C) _I— _ID il
File Options Wiew Control
:I 45 A
44
427
40+
38
36 _I
34
bl S
30
26 :
o—— 0 i
ZE_WWMWWWMW
e
H 24 fime (sec) 99,55
Tirne perdivision:l v|
hd

FIGURE 4-4: EMC1182 Temperature History Graph.
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41.5 Exporting and Importing the Plot Data

The data on each plot window may be stored in a semicolon-separated text file. To save
the data, follow the steps:

1. Stop the plotting by selecting Control > Stop from the plot window, or Control >
Plots > Stop All Plots from the Chip Manager main window.
2. Select File > Export from the plot window to save the data.

To review saved data:

1. Select File > Import from an open plot window and then select the file name to
open.

Note: Importing a saved data file into a plot window with a different data type is
not allowed by the Chip Manager application. In this case, a warning
message will display. It is recommended to choose a file name that reflects
the data type when exporting the plot data.
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Appendix A. Schematic and Layouts

A.1  INTRODUCTION

This appendix contains the following schematics and layouts for the EMC1182
Temperature Sensor Evaluation Board:

* Board — EMC1182 and Interface Schematic

* Board — USB-to-SMBus Bridge Schematic

* Board — Top Silk

* Board — Top Pads

» Board — Top Copper

» Board — Bottom Copper

* Board — Bottom Pads

» Board — Bottom Silk
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Appendix B. Bill of Materials (BOM)

TABLE B-1: BILL OF MATERIAL (BOM)
Qty. Reference Description Manufacturer Part Number
4 |B1,B2,B3, B4 |Bumper blk .3705.19" cylinder Richco®, Inc. RBS-35BK
3 |C1,C6, C8 Capacitor ceramic 0.1 yF 16V 10% X7R Panasonic® - ECG ECJ-1VB1C104K
0603
4 |C2,C5,C7, C9 | Capacitor ceramic 1.0 yF 16 VDC 10% | Panasonic - ECG ECJ-1VB1C105K
X5R 06
C3 Capacitor ceramic 2200 pF Murata Electronics® GRM188R71H222MA01D
50V 20% X7R 060
1 |C4 Capacitor ceramic 22 pF 50V NP0 0603 | KEMET® C0603C220J5GACTU
2 |J1,J2 Header, 2 X 2, 0.1 inch, vertical Samtec, Inc. TSW-102-07-L-D
0 (J3 Header, 2 X 8, 0.1 inch, vertical Samtec, Inc. TSW-108-07-L-D
1 [J3 Header, 1 X 2, 0.1 Inch, vertical, Molex® Connector 22-28-4020
DO NOT POPULATE Corporation
1 [J5 Header, 2 X 4, 0.1 INCH, vertical Samtegc, Inc. TSW-104-07-L-D
1 |LED1 LED red clear 0603 SMT Lite-On® Technology |LTST-C190CKT
Corporation
3 |LEDS3, LED4, LED green SMT Stanley BG1111C-TR
LED5 Electric Co., Ltd.
1 |P1 Connector Header 8 POS 2MM right Molex Connector 87833-0820
angle gold Corporation
1 |P2 Connector recept. USB mini AB Molex Connector 56579-0576
5 POS right angle Corporation
1 |PCB EMC1182 Temperature Sensor Evalua- |— 104-00516
tion Board — Printed Circuit Board
1 Q1 Transistor NPN SOT-23 MMBT3904 Fairchild MMBT3904
Semiconductor®
6 |R1,R2, R4, Resistor 10.0K Ohm 1/10W 1% 0603 Yageo Corporation RC0603FR-0710KL
R14, R15, R16
0 |R10 Resistor 15.0K Ohm1/10W 1% 0603 Yageo Corporation RC0603FR-0715KL
SMD, DO NOT POPULATE
0 |RM Resistor 22.0K Ohm 1/16W 1% 0603 Yageo Corporation RC0603FR-0722KL
SMD, DO NOT POPULATE
1 |R12 Resistor 33K Ohm 1/10W 1% 0603 Yageo Corporation RC0603FR-0733KL
3 |R13,R17, R18 |Resistor 1.00K Ohm 1/10W Yageo Corporation RC0603FR-071KL
1% 0603 SMD
4 |R19,R20,R22, | Resistor zero Ohm 1/10W 5% 0603 Yageo Corporation RC0603JR-070RL
R25
4 |R3, R21,R23, |Resistor 324 Ohm 1/16W 1% 0603 Panasonic - ECG ERJ-3EKF3240V
R24
1 |R5 Trimpot 200 Ohm thumb wheel Bourns®, Inc. 3352E-1-201LF
Note 1: The components listed in this Bill of Materials are representative of the PCB assembly. The

released BOM used in manufacturing uses all RoHS-compliant components.
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TABLE B-1:  BILL OF MATERIAL (BOM) (CONTINUED)

Qty. Reference Description Manufacturer Part Number
0 |R7 Resistor4.7KOhm 1/10W 1% 0603 SMD, | Yageo Corporation 9C06031A4701FKHFT
DO NOT POPULATE
0 |R8 Resistor 6.8K OHM 0.1W 5% 0603, Yageo Corporation RC0603JR-076K8L
DO NOT POPULATE
0 [R9 Resistor 10.0K OHM 1/10W 1% 0603, |Yageo Corporation RCO0603FR-0710KL
DO NOT POPULATE
2 |TP1,TP2 TEST POINT Keystone 5015
Electronics Corp.
1 |U1 Dual Channel 1.8V SMBus/I?C Microchip EMC1182-1-AlA-TR
Temperature Sensor with Resistance Technology Inc.
Error Correction, Beta Compensation
1 (U2 IC 8051 MCU Flash 64K 48 TQFP Silicon C8051F340-GQ
Laboratories® Inc.
1 |U3 IC LDO Reg. 150 MA 1.8V SOT23-5 Texas Instruments TPS76318QDBVRQ1

Note 1: The components listed in this Bill of Materials are representative of the PCB assembly. The
released BOM used in manufacturing uses all RoHS-compliant components.
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